OPENVPN errors when connecting on Mac OSX/Tunnelblick

Hi guys,

so I’ve tried multiple times to set up OpenVPN on my Raspberry Pi B+ following the instructions on

Upon connecting on Mac OSX via Tunnelblick I get the following pop-up:

Use ‘down-root’ plugin for OpenVPN?
The configuration file for ‘DietPi_OpenVPN_Client’ appears to use the ‘user’ and/or ‘group’ options and is using a down script (‘Do not set nameserver’ not selected, or there is a ‘down’ option in the configuration file).

It is likely that restarting the connection (done automatically when the connection is lost) will fail unless the ‘’ plugin for OpenVPN is used.

Do you wish to use the plugin?

regardless of the answer I choose I am left hanging with the message Waiting for server response
I was wondering if anyone else has had problems setting this up using Dietpi. I have a NOIP dynamic dns as well as a changeip dynamic dns (both the free versions)

I have tried both separately to see if the problem lay with either of them however the response is the same for both.

Furthermore… last week, upon installing OpenVPN I was able to connect successfully to my Pi VPN server using the NOIP dynamic DNS however I received the prompt from Tunnelblick saying that the IP had failed to change…

Any help greatly appreciated…

thanks so much guys!

Sorry guys… just to clarify I have forwarded ports 443 and 943 (TCP) as well as 1194 (UDP) and here is the final line in the connection log from Tunnelblick which repeats…

2016-06-01 23:40:19 write UDPv4: Can’t assign requested address (code=49)

thanks again,