OpenBazaar on RaspberryPi 3 B Version 1.2

Hello to All,
No Joy.
I bought a Raspberry Pi 3 B in order to install OpenBazaar using DietPi V 144. This is my third attempt. I have also tried an install of OB on an older Rasperry Pi Model B + gifted to me in 2014.

I am using DietPi on both of my Pi boards without any complaints.

I am not really sure where to begin chasing the problem down because it is a clean install (as are they all)

The only error message that I see is showing on the terminal screen at the login prompt.
[Ok] cron
[Failed] OpenBazaar

The way that I understand it is that only the server part of OB installs on the Pi and the user connects via a client installed elsewhere. And I have been able to see that there are some caveats required via the client such as username password and ports configuration; but I am not at that point yet, because OB does not seem to be running on the Pi yet.

Any help as to where to begin chasing this down will be welcome.

My plan is to run an OB server 24/7 from the Pi. I am just determined to make it work. - period - Any hacker will know how I feel.

And because I guess that I am not the only one, I have decided to set up a page documenting the whole procedure. If this post gets legs, I will share my findings here as I get them. If it does not get legs, I wont.

I am not sure if this is the right venue for this post but it was my first stop. I will continue to scour the net looking for a way to get it going. I did read somewhere that someone claimed to be running an instance of OB on a raspberry pi, but I can not remember where I saw it.

Best Regards from the center of the Multi-verses
44.4N 26.1E


Thanks for the report, i’ll take a look and hopefully get this resolved for you:

Cheers to All,

I tried all morning and into the afternoon searching for a solution.

I checked and changed the micro SD cards. I was using a 16GB Kingston which was on the NG list at

I did not see any problems with that 16 GB SD card. But I swapped it out for the original 4GB card that came with the pi Kit. I could not see any difference at all.

The error messages where the same.
And I have seen that there are many SD card listings. I think that it would be very difficult to find out which list was correct without personal testing. This ambiguity makes the lists neigh on to worthless.

Restarting the OpenBazaar Server service with dietpi-services restart, gives a Failed message (same as always)

When starting via I get an error about unable to find pystun.

That lead me to a long search through python and pip etc. which eventually lead nowhere.

I learned about versioning of python and virtual python folders and none of it seemed to bring me in the right direction towards a solution.

I have heretofore had good results with dietpi. The camera set up is delicious. I have used the picture gallery setup elsewhere; and on dietpi it

also works as advertised. I have been using apache forever. The lighttp server on diet pi is perfect.

As you can see, I am sold on the promise of dietpi.

I already have OB set up on my linux box; But I am fixed by the idea of running an instance of it on the RPi.

I just downloaded the latest raspbian so called “lite”. Lets see what happens with that.

I will go through the motions again using

I will bet that if I am finding difficulties with the installation of OB on RPi, I must not be the only one. The squeeky wheel gets the grease. Let

all who have successfully installed openbazaar on raspberry pi chime in and show us how it is done.

Thank you to the developers for dietpi,

Hi Puggmahone,

We’ve found the cause, the python-pip installation is failing.

The solution is to install the latest python-pip software via the official site:

This will be resolved for v145, however, you can fix this now by running the following:

#Uninstall OB
dietpi-software uninstall 58

#Install python
apt-get install python

apt-get purge -y python-pip
python ./

#install OB again
dietpi-software install 58

Thanks for the quick reply.

I found a similar fix on line yesterday. I am new to python and did not realize that it was the fix that I was looking for.

Late yesterday I did install OpenBazaar on RPi 3 B using the latest Raspbian lite as referenced above. It has been running fine since the install.

But DietPi is my preferred flavor. I will reinstall using your fix on RPi B+ . Thank You. The B+ board is less peformant; but lets see anyway.

Best Regards

Thank you for your fix. It worked perfectly. I got OpenBazaar up and running on the older RPi B+ (ARM6 one core 512 RAM) using DietPi V144.

Then, using the same board, I moved the working V144/OB setup over to boot from a 32GB USB.

Now it is time to rock and roll. I will be adding things on, till I get it “just right” … Lets see what this baby can do.

Has anyone tried running YaCy over JRE?

It works fine on Raspian if you strip it down a bit. (It is sluggish on the single core RPI; but sings on the Quad core RPi )

Plus I want to add a few more things that I use all the time; And just let it run 24/7 attached to my cable modem.

Kind of like an appliance operating for a marginal cost of ZERO…

Best Regards

I have installed Openbazaar on a Raspberry Pi 3B using dietpi-software but OB does not boot. The following error message appears:

root@DietPi:/etc/openbazaar-server# python start -d -a
Traceback (most recent call last):
  File "", line 12, in <module>
    from api.restapi import RestAPI
  File "/etc/openbazaar-server/api/", line 5, in <module>
    import obelisk
  File "/usr/local/lib/python2.7/dist-packages/obelisk/", line 3, in <module>
    from client import *
  File "/usr/local/lib/python2.7/dist-packages/obelisk/", line 3, in <module>
    from zmqbase import ClientBase
  File "/usr/local/lib/python2.7/dist-packages/obelisk/", line 11, in <module>
    from twisted.internet import defer, reactor
  File "/usr/local/lib/python2.7/dist-packages/twisted/internet/", line 38, in <module>
    from twisted.internet import default
  File "/usr/local/lib/python2.7/dist-packages/twisted/internet/", line 56, in <module>
    install = _getInstallFunction(platform)
  File "/usr/local/lib/python2.7/dist-packages/twisted/internet/", line 44, in _getInstallFunction
    from twisted.internet.epollreactor import install
  File "/usr/local/lib/python2.7/dist-packages/twisted/internet/", line 24, in <module>
    from twisted.internet import posixbase
  File "/usr/local/lib/python2.7/dist-packages/twisted/internet/", line 18, in <module>
    from twisted.internet import error, udp, tcp
  File "/usr/local/lib/python2.7/dist-packages/twisted/internet/", line 29, in <module>
    from twisted.internet._newtls import (
  File "/usr/local/lib/python2.7/dist-packages/twisted/internet/", line 21, in <module>
    from twisted.protocols.tls import TLSMemoryBIOFactory, TLSMemoryBIOProtocol
  File "/usr/local/lib/python2.7/dist-packages/twisted/protocols/", line 41, in <module>
    from OpenSSL.SSL import Error, ZeroReturnError, WantReadError
  File "/usr/local/lib/python2.7/dist-packages/OpenSSL/", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/usr/local/lib/python2.7/dist-packages/OpenSSL/", line 124, in <module>
AttributeError: 'module' object has no attribute 'SSL_ST_INIT'

I have read in forums that can be fixed by updating pyOpenSSL with pip but the pip command does not work either.

root@DietPi:/etc/openbazaar-server# pip install --upgrade pyOpenSSL
Traceback (most recent call last):
  File "/usr/local/bin/pip", line 7, in <module>
    from pip._internal import main
  File "/usr/local/lib/python2.7/dist-packages/pip/_internal/", line 42, in <module>
    from pip._internal import cmdoptions
  File "/usr/local/lib/python2.7/dist-packages/pip/_internal/", line 16, in <module>
    from pip._internal.index import (
  File "/usr/local/lib/python2.7/dist-packages/pip/_internal/", line 15, in <module>
    from pip._vendor import html5lib, requests, six
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/", line 86, in <module>
    from pip._vendor.urllib3.contrib import pyopenssl
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/urllib3/contrib/", line 46, in <module>
    import OpenSSL.SSL
  File "/usr/local/lib/python2.7/dist-packages/OpenSSL/", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/usr/local/lib/python2.7/dist-packages/OpenSSL/", line 124, in <module>
AttributeError: 'module' object has no attribute 'SSL_ST_INIT'

Can someone help me, please? Thanks.