OMV intercepts nextcloud setup login with 404 error

hello folks,
First off I want to thank those responsible for this DietPi image.
I have installed nextcloud, open media vault and plex media server when I first set up the DietPi.
OMV is working great and have no issues with it handling my SMB shares and FTP shares.
My problem is that I can’t log into nextcloud to get it configured because when I enter “192.168.X.X/nextcloud” OMV thinks I’m trying to access it since it is on the same local IP and pukes up an error “404 page not found”. :roll_eyes:
Is there another way to log into nextcloud so I can get it configured other that above? :thinking:

Thanks in advance for your help and wishing you all the best

tdlam1

Hi,

OMV isnt fully compatible with DietPi. Although we offer this installation for our users, we recommend if using OMV, solely use OMV and nothing else from dietpi-config or dietpi-software.

The reason for this is we cant control what OMV does, how it wants to do it, or, make it fully compatible with DietPi’s method of standard linux configurations.

Here is an example of how OMV deals with /etc/fstab entries. It wont see any manual + standard entries, unless its contained with the headers # >>> [openmediavault]:
https://github.com/Fourdee/DietPi/issues/721#issuecomment-274332945

Same issue here. I can’t use OwnCloud or Nextcloud. Any way to solve? Thank you

Hi, I have a Raspberry Pi 3 model B with DietPi V147. I’m using it with OpenMediaVault on port 80. I installed OwnCloud via diet-software and if I go to MYRASPI_IP/owncloud I can see an error page from OpenMediaVault. So, I changed OMV port from web GUI to 1234, reinstalled OwnCloud and rebooted but if I type MYRASPI_IP/owncloud I cannot see anything.

I don’t know why.

Sorry for my bad english, is not my mother tongue.

root@DietPi:~# ls /etc/apache2/conf-available/
javascript-common.conf owncloud.conf php5-cgi.conf
root@DietPi:~# ls /var/www/owncloud/
3rdparty console.php db_structure.xml lib remote.php themes
apps COPYING-AGPL etc occ resources updater
assets core index.html ocs robots.txt version.php
AUTHORS cron.php index.php ocs-provider settings
config data l10n public.php status.php
root@DietPi:~#

>

Hi,

Thanks for the report.

I believe the issue is OMV applies a default webserver configuration file, that limits the system to OMV usage only. You’d need to either tweak our default webserver config file (https://github.com/Fourdee/DietPi/blob/master/dietpi/conf/apache2_jessie.conf) to include support for OMV (unsure how at the moment), or, manually add server configs for NextCloud.

We cant control OMV, or really support it along side dietpi-software/dietpi-config, its just not compatible. Ideally, i’d recommend using solely DietPi and the tools available, to replace OMV entirely.

As we cant truly support OMV along side DietPi, I may consider removing it from the DietPi-Software catalog to prevent similar issues reported by our users.

Maybe I can solve removing optimized OMV and install it in the normal way? And then install Nextcloud using Apache2 as web server because I don’t think that may work with nginx.

No idea sorrry, You’d have to try it and let us know if this method works for you.

Ok, I’ll try and I’ll let you know.

Tried in different ways. Following this guide i can see a Nextcloud page via browser but it tolds me that cannot find MySQL driver. I think that is the last problem to solve to have Nextcloud and OMV fully working together.

I have a question: I installed DietPi and change web server from Apache2 to nginx, then installed OMV and Transmission, then nothing else. Can I access to the MySQL database? Maybe via phpMyAdmin?
Thank you

Yep, you’ll need to install phpmyadmin 1st, in dietpi-software under web server: