OdroidC2 qBittorrent login issue

Hello everyone,

I own an OdroidC2 device, however I am pretty new with this programming language but I try to do my best and I already set up my home system to operate with plex and transmission and it is working properly.

Previously I used qBittorrent, as I could set RSS download from torrent sites, and I like qBittorrent more than Transmission.

So, my problem is that, I installed the qBittorrent with dietpi-software and I can’t login to WebUI, even if I am 110% sure I typed in the correct username and password.
I checked and modified the qbittorrent.conf, to have the username and password ‘admin’, but still no luck.

Here is the WebUI config:


When I try to login to WebUI, I receive the following error message:

Invalid Username or Password.

I tried to change the command WebUI\Enabled=true to ‘WebUI\Enabled=false’ to see if it is even uses this configuration, but after I restarted all the services with ‘dietpi-services stop’ and made the changes and than ‘dietpi-services start’, but the WebUI was still working/shown, so it seems it ignored my changes.
I tried it remotely and locally, but none of the way are working.

I hope I provided every detail for troubleshoot. I checked multiple solutions on forums, but none of them are working, I simply not able to login to WebUI. If you need any further info please let me know.

Many thanks and regards,

Note that the used config is: /home/qbittorrent/.config/qBittorrent/qBittorrent.conf

Default username is “qbittorrent” and password your on install chosen global software password, “dietpi” by default.

You run a Stretch image, don’t you? On Jessie default login password is “adminadmin”.


Yes, I edited this file: /home/qbittorrent/.config/qBittorrent/qBittorrent.conf
I tried all the default passwords before I made any change in the .conf file, but none of them are worked.
I tried the following from dietpi.com
Access web interface:
url =
username = qbittorrent (DietPi v6.11 and lower = root)
password = dietpi (Jessie = adminadmin)

Access BitTorrent Downloads:
Make sure you have one of DietPi’s File Servers installed.
folder = downloads

I have the dietpi version 6.22, so I think the qbittorrent and dietpi should work, but it is not working.
So it seems it doesn’t want to let me in anyway. Please let me know if you need any output which could help.

I tried to configure it in a different way what I found on forums, however these were not working as well.
I really need help, as it is really painful to use transmission, so I would like to go back to qbittorrent.
P.S.: My OdroidC2 just received a fresh install, so this is why I lost qbittorrent.

Okay test on my VM:

  • Fresh install: Login via qbittorrent:dietpi works well.
  • Change password via web UI back and forth, login always works with the applied password.
  • Trying to use unencrypted password string inside qBittorrent.conf directly: not possible!, even after service restart
  • What works is removing the WebUI\Password_ha1 line which (after service restart) allows to login via default password adminadmin.

Note: WebUI\Password_ha1=admin seems to be not supported. The password there always needs to be in hashed form. Check as above after removing the line, login via adminadmin password and change it through the web UI. When using password “dietpi” it looks like this:

Note as well: If your changed the DietPi global software password either on first login or afterwards via dietpi-config > Security Options then this new password is applied by default to the web UI login (instead of “dietpi”). This is as well the case when changing the password through dietpi.txt before first boot. Was either of them perhaps the case?


Many thanks! It is working now. The problem was I was changed the global software password, so I tried the default user&pass, and the new global user/pass, but not the default user and global pass. Now I could log in! Many thanks again, you helped me a lot!


I’m afraid it did NOT work for me :frowning:

I have latest DietPi on Raspberry Pi 3
I tried

  • qbittorrent / adminadmin
  • qbittorrent / dietpi
  • qbittorrent / which I changed at first boot
  • deleting the indicated line from the conf file + restarting the service

No joy. The qittorrent gui won’t let me in.

Help! :cry:

Do you get an actual “wrong user/password” error message when trying to login? If not, please try another browser.
For reference, see here: https://dietpi.com/forum/t/qbittorrent-login-issue/3202/1

If this indeed works, please report back which browser did work and which not, so we can forward to qbittorrent devs.