Odroidc2 problems

Hello guys,

I was adding packages to my OdroidC2 when i goofed up. Oh well, a fresh reinstall then…

After that things went wrong. When i was ready with every fresh install, after a reboot i would get kernel problems. (or a corrupted file system!). I tried a new sd-card, different dietpi-versions (test and stable). All give me problems AFTER a reboot.

I am wondering if there’s a hardware problem with this Odroidc2 …

ps: also tried armbian’s debian server, same thing.

Any tips?

Try another power supply?


It’s the “official” power supply, but i will have a go at it.

Thanks for the tip!

ps: which reminds me! i removed a jumper to disable the usb-powersupply (get the temp down from the cpu), Maybe related!

I’ve done the jumper thing on my two C2s, both run well.

If you’ve eliminated the SD card, the distro and the power supply (and power supply cable) then the only possibility can be the C2 has developed a fault? Or an idea that has just occurred to me is to use the Odroid version of Win32 disk imager with verify on to flash the SD - assuming you are flashing the cards on a Windows system that is.


Hello John,

I use etcher on windows 10/64 bit. What is the " Odroid version of Win32 disk imager" ?

ps: this one? http://dn.odroid.com/DiskImager_ODROID/Win32DiskImager-odroid-v1.3.zip

Yes that looks like what I was meaning.


Hello John,

I am up and running! But things didn’t go as i thought they would have. I did use etcher again but this time i formated the sd-card before i started flashing. I used an other (usb) power suply (only 2 Amp’s, but it works)

Thanks again for all the tips!

ps: i didn’t install head-less this time (ssh) but used a hdmi-cable/monitor. Is a red screen normal for dietpi? (in ssh it is black)


It is more a pink/magenta background, if you connect a LCD monitor via hdmi cable to your Odroid C2.

Nothing to do with dietpi, more with Odroid default configuration.
If you want to change this, you have to choose the correct HDMI output resolution, HDMI BPP Mode, HDMI DVI/VGA modes, and so on in boot.ini

And a lot of try and error until it will work.

Have a look: