Odroid Xu4 Read and write speeds

Hallo community,

i have a question regarding the read and write speeds for my odroid.

I have the computer build in the cloudshell with a 250gig samsung 850evo.
For testing purposes i opened the cloudshell and connected my external storage WD Elements which is rated to have usb 3 *usb 3 cabel connected. Copyed a 962,8mb mkv file from my ssd to my ntfs external storage WD Elements. It copyed 5 minutes and 9 sec. Which is 3,11 Mbyte per seconds.

After that i took my usb 3 stick from Transcenent which is ntfs and tryed the same… Nearly same time.

After that i formated the usb stick to ext4 and retryed the same. Now it is faster and copyed the mkv file in around 43sec. Which is 22 Mbyte per seconds.

After this test formating usb stick to ntfs. Copying same file to stick needed 3min47sec which is 4,64 mbyte per sec

I dont want to format my WD external storage because it is completly full.

Can anyone tell me why the speeds are so slow

A i also tryed to copy the mkv file from my external storage to my SSD, which is build in the cloudshell.
I needed for 962MB around 15 sec which is about 60Mbyte per sec.

Can anyone explain to me why i have that slow writing speeds to my external storages, which are rated to be usb3


Hi Solleto,

3mb/s is slow. Something not right there. May be insufficient power.

If you plan to use the HDD permanently in your cloudshell, you should format with EXT4, it is faster than ntfs-3g.

You can run a filesystem benchmark for your USB drive with dietpi-config > Tools > Benchmarks.
Or run the following to take you straight there.

dietpi-config 11

Heres mine for comparison (Cloudshell + XU4):

  • USB Drive = Hitachi 5400rpm HDD through cloudshell
  • 1000mb file size (1gb)
  • SD card = Sandisk Extreme 16gb (write speed is slow as its doing stuff ) :slight_smile:

yea i tryed the tool. With the ssd which is ext4 i have

USBHDD: Write = 75.4 MB/s | Read = 91.0 MB/s

i cannot test the WD Elements external storage. It is connected at the second usb 3.0 slot.

I dont get a selection screen. Hm i was hoping that i have the same speed with ntfs. Because i want to use the external storage on my windows computer too.

Creating NAS for distributing datas on local wifi is making problems due to very slow transfer speeds of 3 to 10 mbyte per second

Strange, 3mb/s it shouldn’t be that slow. Maybe it doesnt like the sata controller in your WD elements device.

A few things to try:

  • Have you tried unplugging the cloudshell USB whilst testing the WD elements external drive?
  • What speed do you get on windows with the WD elements?
  • If the WD elements has its own PSU (implies 3.5inch), have you tried plugging the WD elements drive into the USB2.0 socket on the back of your XU4?

Also, very important:

  • if you are using more than 1 HDD on your DietPi system, make sure you use UUID’s in fstab to prevent “drive mount swap”.