Odroid Xu4 Kodi NO SOUND

Fresh Install of DietPi headless.

FTP, SMB sharing installed & working.
Xfce desktop installed & working (not needed but just curiosity)
VNC installed & working.

So far very impressed with ease of use.

Kodi installed.
Functions fine selecting & playing back locally shared video files through hdmi to TV… but no sound!
Tried fiddling with Kodi settings. No dice.
Am I wasting my time? Does this not work on DietPi with XU4?


Hi Jake,

Thanks for the report.
Should be working fine. Let me create a ticket and try to replicate on my XU4: https://github.com/Fourdee/DietPi/issues/625

Hi Jake,

Will need some more information on your system and its configuration, can you please send us a bug report: https://dietpi.com/forum/t/send-dietpi-a-bug-report/421/1

Hi Jake,

I had the same problem with only kodi installed and set as autostart kodi.

discovered that the pulseaudio device was not indentified.
the device that was present to select as audio device (default=hdmi or odroidaudio) none of them worked.

steps done to troubleshoot

  1. Installed the LXD desktop
  2. changed settings to autostart desktop.
  3. running kodi from desktop Yeah I have sound
  4. changed setting back to autostart kodi
  5. reboot
  6. Yeah I have sound. and the pulseaudio device is now available to map as sound device

good luck.