Odroid XU4 Freezing after login or launching an application.


I downloaded the latest image for Xu4 : DietPi_OdroidXU4-ARMv7-Stretch

After configuration is complete when I login using LXDE I can start an application and then the desktop freezes with a spinning cursor. This does not error out or recover.

I performed another install after re-flashing with Etcher and when using another desktop it froze right after login.

The configuration seemed to go fine and was responsive and I did not notice any errors during that phase.

I am using a 16GB EMMC chip and I am using the provided adapter to flash this. My previous image was Ubuntu 15 so I am not sure if there is a boot loader update that was missed. Please and thanks for any suggestions.

Maybe try an SD card to eliminate the eMMC as the source of the problem? I had two eMMCs fail.


The Emmc I have worked before via Ubuntu 15 and after via Ubuntu 18 using odroid supplied images. Both 3rd party images dietpi and armbian that I tried had issues and failed to boot or boot to a useable desktop. I’ll flash an sdcard and will report, if it makes a difference. Thanks and please let me know if there are any other suggestions.


Image: DietPi_OdroidXU4-ARMv7-Stretch.

I have the same problem (LXDE / XFCE) it freeze when i launch a app. I’m using a 32GB Emmc with the USB adapter (all bought from odroid Hardkernel)

I didn’t have any problem with the Ubuntu MATE (installed in the Emmc)

I didn’t try with a SD yet.