Odroid XU4 + bullseye + plex restart

I have a odroid xu4 + latest dietpi.
In the last days, when i start the plex client, the dietpi server restart.
How can i resolve this?

You could try to enable persistent system logs. Thi should allow you to see what happen right before the boot happen.

dietpi-software uninstall 103 # uninstalls DIetPi-RAMlog
mkdir /var/log/journal # triggers systemd-journald logs to disk
reboot # required to finalise the RAMlog uninstall

Then you can check system logs via:


which will then show as well logs from previous boot sessions. To limit the size, you can additionally e.g. apply the following:

mkdir -p /etc/systemd/journald.conf.d
cat << '_EOF_' > /etc/systemd/journald.conf.d/99-custom.conf

This will limit logs to 14 days split across two journal files, so that with rotation you will always have between 7 and 14 days of logs available.

thanks, but randomly restart

i want to install this, but restarted the system. maybe i reinstall the system.

Have a look to your PSU or power cable. Try to change if possible. Just to have it excluded.

I run stress test, and it all okay.

Indeed of the stress test succeeds, power shouldn’t be the issue, but it’s not necessarily ruled out.

However, when president system logs are enabled now, don’t they give a hint? E.g. checking the last log entries from before the crash via journalctl?

I dont see, the probleme.
This is the last journalctl

Indeed, last log is from Avahi daemon, next is next boot session :thinking:. Looks like it crashes so immediately that no system logs can be done.

How about RAM (htop) and disk usage (df)?

I replaced the power supply, and resolved the problem. So, your first tipp is solved.

Ah that is great.