Odroid N2 V8.24 doesn't boot

I just updated my Odroid N2 to the latest beta version, 8.24.1, but encountered a boot issue. During the initial boot process, an error message related to EXT4-fs appeared, leading me to suspect a corrupted SD card.

To address this, I opted for a clean install, downloading the most recent image from the official website. Initially, the system booted successfully and began the automatic update process. However, it failed to reboot afterward, displaying the same EXT4-fs error as before.

I have attached a photo that captures the error message in more detail.

did you use the very same SD card? If yes, probably you can try another one.

Here’s how I managed to restore my system to a functional state:

I performed a clean installation but this time, I disconnected the Ethernet cable to prevent the system from accessing the internet and automatically updating. Then, I used the DietPi restore utility to revert to a previous backup I had saved.

Now my system is functioning properly and I’m on version 8.24.1 but it’s asking me if i want to update the following packages : armbian-firmware libtiff6 linux-dtb-current-meson64 linux-image-current-meson64
linux-u-boot-odroidn2-current

Which was what i had updated earlier and borked my system

We have a built-in function to restore backups already on first boot. No need for this workaround.

Anyway. To exclude issues on the running SD card, you would need a spare one and test with a new fresh install.

I see the same symptoms updating DietPi on an Odroid N2+. The update of the OS appears to go OK, but things seems to go bad at the end of the apt update.

Storage is a properly-set-up-for-boot USB SSD. The same failure occurs for a fresh install (downloaded image today) on a different HDD. Both the SSD and HDD are readable when mounted on a working Linux system.

Maybe something with latest kernel package. As we don’t develop this kernel, it would be needed to test with plain Armbian to see if it’s similar with latest kernel builds.

I’ve tried installing a saved old image that worked earlier, but it wants to automatically update to the latest (broken!) version. How can I safely suppress that automatic update?

you could boot without network connection and interrupted the install. Afterwards, put kernel package on-hold.

But would be good if someone could test with native Armbian image.

1 Like

Could you please specify which are the kernel package on hold? I put on hold this packages (armbian-firmware linux-dtb-current-meson64 linux-image-current-meson64, linux-u-boot-odroidn2-current), but Odroid N2+ still doesn’t boot after updating the rest of the packages.

do you know the packages that should be updated? can you share them?

These were the packages needed to be updated:


armbian-firmware/bookworm,bookworm 23.11.1 all [upgradable from: 23.8.3]
base-files/stable 12.4+deb12u2 arm64 [upgradable from: 12.4+deb12u1]
cloudflared/unknown 2023.10.0 arm64 [upgradable from: 2023.8.2]
containerd.io/bookworm 1.6.25-1 arm64 [upgradable from: 1.6.24-1]
curl/stable-security 7.88.1-10+deb12u4 arm64 [upgradable from: 7.88.1-10+deb12u1]
dbus-bin/stable 1.14.10-1~deb12u1 arm64 [upgradable from: 1.14.8-2~deb12u1]
dbus-daemon/stable 1.14.10-1~deb12u1 arm64 [upgradable from: 1.14.8-2~deb12u1]
dbus-session-bus-common/stable 1.14.10-1~deb12u1 all [upgradable from: 1.14.8-2~deb12u1]
dbus-system-bus-common/stable 1.14.10-1~deb12u1 all [upgradable from: 1.14.8-2~deb12u1]
dbus-user-session/stable 1.14.10-1~deb12u1 arm64 [upgradable from: 1.14.8-2~deb12u1]
dbus/stable 1.14.10-1~deb12u1 arm64 [upgradable from: 1.14.8-2~deb12u1]
debian-archive-keyring/stable 2023.3+deb12u1 all [upgradable from: 2023.3]
debianutils/stable 5.7-0.5~deb12u1 arm64 [upgradable from: 5.7-0.4]
docker-ce-cli/bookworm 5:24.0.7-1~debian.12~bookworm arm64 [upgradable from: 5:24.0.6-1~debian.12~bookworm]
docker-ce/bookworm 5:24.0.7-1~debian.12~bookworm arm64 [upgradable from: 5:24.0.6-1~debian.12~bookworm]
libcurl3-gnutls/stable-security 7.88.1-10+deb12u4 arm64 [upgradable from: 7.88.1-10+deb12u1]
libcurl4/stable-security 7.88.1-10+deb12u4 arm64 [upgradable from: 7.88.1-10+deb12u1]
libdbus-1-3/stable 1.14.10-1~deb12u1 arm64 [upgradable from: 1.14.8-2~deb12u1]
libgssapi-krb5-2/stable 1.20.1-2+deb12u1 arm64 [upgradable from: 1.20.1-2]
libk5crypto3/stable 1.20.1-2+deb12u1 arm64 [upgradable from: 1.20.1-2]
libkrb5-3/stable 1.20.1-2+deb12u1 arm64 [upgradable from: 1.20.1-2]
libkrb5support0/stable 1.20.1-2+deb12u1 arm64 [upgradable from: 1.20.1-2]
libnghttp2-14/stable-security 1.52.0-1+deb12u1 arm64 [upgradable from: 1.52.0-1]
libpam-modules-bin/stable 1.5.2-6+deb12u1 arm64 [upgradable from: 1.5.2-6]
libpam-modules/stable 1.5.2-6+deb12u1 arm64 [upgradable from: 1.5.2-6]
libpam-runtime/stable 1.5.2-6+deb12u1 all [upgradable from: 1.5.2-6]
libpam0g/stable 1.5.2-6+deb12u1 arm64 [upgradable from: 1.5.2-6]
linux-dtb-current-meson64/bookworm 23.11.1 arm64 [upgradable from: 23.8.1]
linux-image-current-meson64/bookworm 23.11.1 arm64 [upgradable from: 23.8.1]
linux-u-boot-odroidn2-current/bookworm 23.11.1 arm64 [upgradable from: 23.8.1]

I installed all of them except these:

armbian-firmware/bookworm,bookworm 23.11.1 all [upgradable from: 23.8.3]
linux-dtb-current-meson64/bookworm 23.11.1 arm64 [upgradable from: 23.8.1]
linux-image-current-meson64/bookworm 23.11.1 arm64 [upgradable from: 23.8.1]
linux-u-boot-odroidn2-current/bookworm 23.11.1 arm64 [upgradable from: 23.8.1]

Now the Odroid N2+ boots ok. I now for sure that one of these packages have problems. I think is the linux-u-boot-odroidn2-current/bookworm 23.11.1 arm64 [upgradable from: 23.8.1].
I will test one by one and get back to you.

So I found out that for me only this package ruins the boot of Odroid N2+!!!
linux-image-current-meson64

as thought it is one of the kernel packages. Best would be to perform same test with original Armbian image.

On my N2+ Armbian 23.11.1 and Dietpi 8.24 function without issue when run from an SD card.

My goal is to get Dietpi running from SSD only (no SD). Modifying /boot/boot.cmd (and compiling to boot.scr with mkimage) on the SSD allows the system to boot and the OS to partially start up but then fail – for both Armbian and Dietpi.

Armbian:

Dietpi is more verbose:

Strange! It appears to me that disk access works at first, but then fails.

Looks like latest kernel version has some challenges. Best is to test with plain Armbian and if it behaves same, have it reported directly to Armbian. Just one remark, if you go to report to Armbian, don’t do any comments or similar about DietPi. We don’t have best relationship. Therefore it is needed to use original Armbian and their debugging tools :wink:

sudo apt-mark hold linux-image-current-meson64

Temporary fix, while allowing you to keep your machine updated

1 Like