Odroid HC4

Hello -

I have an ODroid HC4 with petitboot 20211112. I have imaged DietPi_OdroidC4-ARMv8-Bullseye, dated 15 Feb 2022, with balenaEtcher. Petitboot recognizes the image. It will start to boot, but fail because it can’t find the deb file. The correct dtb file appears to be located in “dtb/amlaogic/meson-sm1-odroid-hc4.dtb”. I can update boot.cfg and recompile, but the boot then hangs at seemingly random places, but always after removing and re-creating the swap file.

DietPi has always supported my hardware extraordinarily well. Has anybody run it on the HC4 lately that could provide me some insight?



I guess you need to bypass Petitboot (keep button pressed on powe-up) https://github.com/MichaIng/DietPi/issues/5269#issuecomment-1043118746

Hi jerhoads,

I have the very same board and I am facing the same issue: it seems to be very common if you google on it…
About a year ago, when I was using / experimenting OMV5, therer were times that it wouldn’t boot. It depended on ‘how’ I installed everything.
I have tried many aproaches (NetBoot install of Debian, OS-Images from Hardkernel or Armbian) and afterwards scripted installs of Armbian, OMV DietPi, etc.

Now I am using the same DietPi-image you took (latest Dietpi with 5.10 kernel). Petitboot could boot from it and the initial installation of DietPi was totally fine. BUT… I couldn’t reboot anymore.

This morning I ‘finally’ dare to decide to remove the Petitboot / Erase SPI, and presumed / hoped that this was the solution to bring back the abillity to reboot. Sadly that is not the case. Going back to the old kernel is not an option either, so I’ll leave it this way and hope somebody finds a really solution.

Have you tried anything?

Regards, Frank

I believe that keeping the button pushed at power-on just maps the micro-sd to MMC, which is necessary because MMC is hardcoded into the boot.cfg file on DietPi. I mapped the kernel to “/dev/sda1”, because I am booting off of an SSD drive. The boot process appears to work, it just hangs after a few seconds at seemingly random places.


Hey Frank. I know that a really old image (c 2019) is available on archive.org. Is there possibly a way that you know of to roll back just a few builds?


No I don’t know about it. But today I finally managed to get my HC4 working good on DietPi.
See https://github.com/MichaIng/DietPi/issues/5269#issuecomment-1050676202 for more details.

However, I am booting from SD and NOT from SSD.

I would first try to do an initial install of DietPi on SD (without the SSD mounted):

  • using the latest image from today on DietPi-website
  • after base-install, flash SPI/Petitboot with the following command
flash_erase /dev/mtd0 0 0
  • then run:
sudo apt update && sudo apt upgrade

Finally verify that you can reboot the system by:

sudo reboot now

If everything is working fine, you can go further and perform the steps to transfer the system to SSD.

The boot-partition (on SD) has changed a lot if compared to the old legacy one (buster kernel 4.9).
So, if you made changes in the old boot.ini, that must be done in a different way I do not know.

These are next steps that I have to figure out: how to get the RTC-clock running and use the IR-remotecontrol to switch the system on or off.
Maybe I’ll have to search in the Armbian- forums.

Grtz, Frank