Odroid HC4 won't boot from SD card without pushing Black Button

Creating a bug report/issue

Required Information

  • DietPi version | 8.18.2
  • Distro version | bullseye
  • Kernel version | Linux DietPiO 4.9.312-arm64
  • Architecture | arm64
  • SBC model | Odroid C4/HC4 (aarch64)
  • Power supply used | 15 V / 4 A (official power supply)
  • SD card used | Samsung EVO

Additional Information (if applicable)

  • Can this issue be replicated on a fresh installation of DietPi?
    → Yes

Steps to reproduce

1a. Shutdown HC4, remove power and bring power back
1b Restart HC4

Expected behaviour

  • DietPi should boot

Actual behaviour

  • Only Hardkernel logo is visible via HDMI
  • DietPi doesn’t react via Ethernet

Extra details

Hello everyone,

this is probably an issue of the ODROID HC4 and not of DietPi itself, but maybe some of you have had this issue as well and can help out. During the weekend, we had a power outage. When the power came back, DietPi didn’t come back. My Pi-Hole wasn’t working, etc. So I tried to access it via DietPi, but there was no response.

I then prepared another SD card with a clean image if DietPi, but the same thing happened. So the issue was not that the SD card was corrupted. After a lot of research, I came across a thread in the ODROID forum:

It was recommended to push the black button on the bottom of the HC4 and see if that helps. And it actually did. When pressing it, I can properly start DietPi from the SD card. Now I don’t want to press this button every time DietPi restarts. So I tried to follow the steps described in this thread and get rid of the SPI flash memory. I downloaded the image to update the SPI. I could boot the image (while pushing the black button), but entering the following commands ended with an error:

# flash_eraseall /dev/mtd0
# flash_eraseall /dev/mtd1
# flash_eraseall /dev/mtd2

Within /dev, there are no folders with the names mtd… I wanted to reply in this thread and get additional help, but the e-mail required to enable my account doesn’t arrive. So can anyone here give me tips as how to resolve my issue? I also wonder why this only started happening now. I have the ODROID HC4 since 2021 and never had such issues until now.

I don’t have a HC4 but maybe @StephanStS or @MichaIng

@MichaIng: Would greatly appreciate your support. I assume you are already aware of this topic, as there has been a GitHub issue about it:

My problem is that the SPI update image provide here does nothing:

I only end up in the petitboot screen where I can go to the console. But as there is no /dev/mtd, I can’t delete it.

So I’m not sure how to proceed. How can I get back to (re)starting my ODROID HC4 without having to push the black button?


This topic may be closed. I was able to register in the ODROID forum and got the help I needed there.

My fault was that I kept pushing the black button until the blue LED started blinking. But I should have let it go once the blue LED was lighting up constantly. Was able to repair the SPI firmware and then delete the mtd0 to mtd2 sections successfully.

1 Like