Odroid HC-1

For all who are interested in the Odroid HC-1 and DietPi, here some benchmarks, results and informations i got so far.

Working Images so far:
Normal XU4 Image “DietPi_OdroidXU4-armv7-(Jessie).7z” based on Kernel 3.10.105+ = works :smiley:
Normal XU4 Image upgraded to 3.10.106+ = works :smiley:
Test Image XU4 on GitHub: Test Images “XU4 | Kernel 4.9 testing #926” = works :smiley:

Hardware Test Setup:

  • Odroid HC1
  • Test Image with Kernel 4.9
  • 1 TB WD Red
  • CMOS Batterie
  • passive cooling

Software running:

  • NetData
  • SyncThing
  • Python 3.6.3 (manually update) (i need it :sunglasses: )
  • LLMP Package
  • iperf
  • SysBench
  1. SysBench

    Interesting result, when i compare it with the results of XU4 in another thread here in the forum.

  2. iperf - first run (Server side = W7 x64 Iperf 2 / Gbit USB 3.0 Adapter) (Client Odroid HC1)

    If anyone have some further interesting tests i could do, just tell me, so far my freetime allowes it, i’ll test it.

Further news are coming next days :mrgreen:

Thanks for this info.

Thanks for this @secpri!!

This Youtube vid shows the HC1 transferring larger files at a steady 90ish MB/sec. Which blows the likes of the Raspberry Pi (expect 3.5MB/sec) and the Tinkerboard away. Sure, the tinkerboard has a Gigabit ethernet port (~120MB/sec theoretical max), but how are you going to attach a SATA drive? You’re limited to what the USB 2.0 ports can provide (say, with a USB 2.0 2.5" SATA enclosure). So maybe 20 MB/sec of realworld performance?

I’ll soon be getting a laptop with a Gbit ethernet port, so to me, an Odroid HC1 + decent 2.5" SATA drive + DietPi seems like a very inexpensive but decent file server option (and I love DietPi’s automated install of Nextcloud in dietpi-software), which would come close to maxing out the laptop’s Gigabit ethernet capabilities. 90MB/sec is a far cry faster than ~20MB/sec or 3.5 MB/sec.

I would very much like to see the Odroid HC1 gain official support on the DietPi’s “Odroid” section (on the website’s front page).

Thanks to everyone who worked on DietPi! :smiley:

Sure, I have a test for you. I’d like to know what kind of hard drive speeds you are able achieve with “hdparm -t”. If your 2.5" SATA disk, is, say, “/dev/sda” (in DietPi), then what output do you see (when the system is idling quietly) with:

hdparm -t /dev/sda

(You probably already know this, but in case you don’t, the “mount” command should give you output which lets you deduce which device file is the SATA drive.)

Test result:

The Sata Controller is connected via USB 3.0 not 2.0, so you have a theretical max of about 625 MB/sec. (5Gbit/s), therefore
i have placed in a Samsung 850 SSD (about 550MB/s), the practicaly test shows a value of about 326 MB/s in reading mode.

From you context you had the same problem then me before using Odroid XU4 oder HC1, at moment i am testing my HC-1 in a business installation, making backups of about 1.000.000 files with a space amount of about 750 GB. Right now it works faster then mostly NAS, which i saw in the past, and the 90 Mb/s are realistic on large files.

My big problem was in the past, that also quality NAS System mostly are do not more then 25-45 MB/s over LAN, with Odroid HC1 i could solve this issue.

Further you should not compare the odroid hc1 with a real fileserver (IBM/HP/DELL/etc), as this is another league, but as NAS with nice fast transfer, it works very well and is cheap on top.

Thanks for mentioning that!!

Just FYI.

I live in Canada, and the vendor in this area is called “Ameridroid”: https://ameridroid.com

I decided to find out how expensive the shipping was (sending it across the Canada-US border) by putting an HC1 into a shopping cart there. They say “We strive to ship the HC1 same day when possible. However, due to high demand, some orders may be delayed.”

The HC1 is $49.95 US. Shipping to Canada by USPS (Very favourable! It’s not a courier!) only adds another $15.95 US (“USPS First Class to Canada (delivery time varies by location) - No tracking or insurance available”).

PS: I don’t work for Ameridroid or Odroid. I’m sincerely impressed that USPS (U.S. Postal Service) is a shipping option.

FTP-Speed - large file @ Samsung SSD