Odroid C2 - Sound drop with passthrough

Hi all!

I am the happy owner of an odroid C2 running on DietPi.
Everything seems to be running really well but one thing: I get some sound dropouts every few seconds when I play a movie with Kodi and enable HDMI passthrough.
This seems to happen only when HDMI passthrough is enabled.

Is anyone facing the same issue and was able to fix it?

I have tried Librelec on the same Odroid C2 and the passthrough works like a charm.


Hi Mez,

Might be something we can track in kernel log. After the issue occurs, please paste the results of the following (its a big one) and i’ll take a look:


Here is the output of the dmesg command (file attached).
The sound drop seams to occur pretty much every 6/7 seconds.
It’s very short. It sounds like if the sound was skipped forward for 1/8 of a second.
I tried various video files. Seems to happen with dolby or dts.
Thanks for looking into it, let me know if there is anything else you need!

log.zip (11.5 KB)

Thanks Nicolas,

Yep, definetly something going wrong here, appears it keeps enabling/disabling the IEC958 HDMI:

[91222.365300] aiu i2s playback enable
[91222.365328] audio_hw_958_enable 1
[91222.461534] aiu i2s playback disable
[91222.461552] audio_hw_958_enable 0
[91222.461625] [aml-i2s-dai]i2s dma ffffff800048e000,phy addr 1611005952,mode 2,ch 2
[91222.461631] ----aml_hw_iec958_init,runtime->rate=44100,sample_rate=5--
[91222.461635] aml_set_spdif_clk rate
[91222.461648] divider=22,frac=13030400,SDMval=2364
[91222.461660] set normal 512 fs /4 fs
[91222.461667] iec958 mode PCM24
[91222.461677] IEC958 24bit
[91222.461685] hdmitx: audio: aout notify rate 44100
[91222.461689] hdmitx: audio: aout notify size 32
[91222.461694] 958 with i2s

Any chance you can take a picture of your current audio settings screen in Kodi? The one under System settings. I’ll see if I can replicate on my C2.

Also, have you tried a different HDMI cable, and whats your power supply being used (eg: Official HK 5v/2A)?

Hey Fourdee!

I use an iphone charger over the OTG usb port. It is 5v/2A.
I’v attached the pictures of the sound configuration.
I will try to find another hdmi cable and get back to you once I tried. But again: I tried the same hardware setup with Librelec and didn’t get the issue.
Don’t hesitate to let me know if I can provide anything else.

KodiSound.zip (525 KB)

Thanks Nicolas,

I’ll run some tests tomorrow and get back to you.

Regarding the charger, I would highly recommend a Raspberry Pi PSU, it provides a stable 5v/2A. I’ve had many issues with Samsung chargers that drop their voltage below 4.5v, although, to be sure, you’d need one of these to test the voltages of the iPhone charger are a stable 5v under load. Power may not be the issue, but its the most common cause of problems on SBC’s.

Hi Nicholas,

Apologies for the delay, i’ve created a ticket and will try and get round to this in the next few days: https://github.com/Fourdee/DietPi/issues/626

No worries Fourdee, thank you for looking into this and reacting so quickly. It’s great to see how you guys are committed and helpful!

Hi Nicolas,

Ok, unable to replicate on my system, but I have few things we can try, although, its going to be a case of trial and error until we find the cause:

In Kodi > System settings > Audio options
Set the following:

  • Support 8 Channel DTS-HD audio decoding: Off
  • Keep audio device alive: 1 minute
  • Limit Sampling Rate: 44.1Khz

If you still experience dropouts, please check and update kernel package:

apt-get update
apt-get dist-upgrade -y

You can check current kernel with uname -a, latest is:

root@DietPi:~# uname -a
Linux DietPi 3.14.79+ #1 SMP PREEMPT Sat Nov 12 19:20:38 CET 2016 aarch64 GNU/Linux

Lets check your asound.conf, please paste results:

cat /etc/asound.conf

Hi Fourdee,
So here you are:
With the settings you suggested, I do not have sound drops.
As soon as I enabled passthrough, keeping the same settings, I got the sound drops.

I am at the latest kernel:
Linux DietPi 3.14.79+ #1 SMP PREEMPT Sat Nov 12 19:20:38 CET 2016 aarch64 GNU/Li       nux

root@DietPi:~# cat /etc/asound.conf

pcm.!default {
    type hw
    card 0
    device 0
ctl.!default {
    type hw
    card 0
    device 0


Hi Mez,

Thanks for the info.

If you can remember, was it the 8 Channel DTS-HD audio decoding: Off setting that prevented the sound drops, or, enable passthrough?

The only thing I can recommend is (if you haven’t done already):

  • Try another HDMI cable
  • Update Firmware on your TV and/or try another TV.

Failing that, you may get more joy from the Odroid forums.
The Kodi package is maintained by Meveric, so would be worth searching his forum post and see if other users had similar issues: [OS] Debian Jessie (arm64) - ODROID

Hi Fourdee,

Thanks for all your efforts!
It is really only the enable passthrough:Off which prevents the sound drops.
I tried another HDMI cable and a different charger (but still not official one).
Note that the C2 is connected to a Denon receiver, not directly to the tv.
I guess I will just live without the passthrough. All the rest works perfectly!


Hello all.

Having the same issue (1 click every 10s), I was wondering if things were getting any progress about passthrough ?
Indeed, Kodi v17 is out now and “might” correct things, no ?



Because the issue is visible at kernel level (dmesg):

I believe it may a bug in the kernel. But we wont know for sure, until our Odroid C2 image is updated to Stretch, which should bump Kodi up to v17 (pending Meveric’s package changes), and could exclude kernel as the cause.

As i’am unable to replicate the broken sound at my end, i’d highly recommend posting this on the Odroid forums to hopefully get some suggestions/solutions:

Also, which board revisions are you guys running?

Hi all,

it’s been a while now that I scavenged the forums and every “tips & tricks” things to try to get this passthrough problem solved.
I tried the ALSA SINK solution. doesn’t work for me. Seems to be a hack for the Odroid C1.
Tried with Hifi Plus board … doesn’t change the problem.
Tried going back to original Odroid linux ubuntu install (on the eMMc) (v16 i guess). Doesn’t have the passthrough option and enabling it with commmand line crashed Kodi.
Tried with Kodi v17 (Krypton). nothing new.
Tried several different resolution setups : 4K,2K,HD and different frame rates. Because I thought that might be a synchronisation problem between video feed and sound. Nothing on that end either.
The only OS that worked out fine is LIBRELEC. But in this case I cannot install my cloud, ftp etc.

So, I’m running a little bit out of options and still be annoyed to get a sound stutter every 10 seconds on DTSHDs videos. (But the sound feels sooooo greater than in PCM ! Is it just me ?)

I’m still in v159 with ODROID C2 board, having everything working well… except that audio thing.

I’m lazy to upgrade to Dietpi V6 since everything is going great now, with minimum IT annoyance.
I really feel Dietpi is the best solution for me with everything simplified and all.

My question now: is the problem solved in Dietpi V6 (v160+) and I’d better take a day to reinstall everything ?
Or drop it.

It’s a shame because ODROID C2’s board are great.

Why not try on a second SD card?


Sure that’ll be the plan, of course.

The main question is : Does someone has the same problem of passthrough that may have be corrected with the upgrade ?