Odroid C2 plex & transmisison & HDD problem

Hello all,

I’m not really familiar with the commands for troubleshoot the problem so I would need a detailed solution with the commands.

I have some repeating problem with my device and HDD. I have a 8GB Kingston memory card.

First problem:
When I try to play a movie or serie on the Plex it says “Not enough disk space to convert this item.”.
After that I tried to set the “Transcoder temporary directory” to the HDD but it still had problems.
I just noticed that the memory card is totally full:

root@DietPi:~# df -h
Filesystem Size Used Avail Use% Mounted on
udev 717M 0 717M 0% /dev
tmpfs 172M 8.7M 164M 6% /run
/dev/mmcblk0p2 7.2G 7.2G 7.5M 100% /
tmpfs 859M 8.0K 859M 1% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 859M 0 859M 0% /sys/fs/cgroup
/dev/sda1 916G 429G 442G 50% /mnt/HDD1
tmpfs 1023M 0 1023M 0% /tmp
tmpfs 20M 16K 20M 1% /var/log
tmpfs 10M 1.5M 8.6M 15% /DietPi
/dev/mmcblk0p1 128M 45M 83M 36% /boot

I had this problem last time, but my friend could solve it. He said me that the problem was with the transmission, because it started to download the movie to the SD card, after a transmission error, when it couldn’t reach the HDD1.

Could this be the problem again? And if it is, how can I check it, or delete the file/process to download it to the SD card?

Second problem:

I have a 1TB HDD, it is about 4 years old, but I think it should work properly (maybe the case is poor quality).
The problem is the dietpi dismounts the HDD about once every day. I’m running plex and transmission only.
I checked the logs earlier (unfortunately I don’t have it anymore), and it showed the dietpi tried to remount the HDD, but it wasn’t successful, only the reboot of the dietpi solved the problem. We tried to fix the issue with “crontab” (I don’t know this command, my friend configured it) so we set a dismount and remount for every 30 minutes. It is better now, but sometimes it happens again so not the transmission or plex could reach the files.

Any idea?

P.S.: I think maybe overheating problem could cause the problem as the HDD case is a little bit too hot.

Third problem:

When the HDD is reachable, and everything works fine (almost everything) the transmission pauses some torrents while the others keeps running. The “service transmission-daemon restart” command solves the issue, but it happens too many time, and it is really annoying. There is no limit set to download/upload and active torrents.

Any idea?

Thanks in advance for the help all of you. If you need any output from the device, just ask and I will send it.