Odroid C2 Installation Fails

I have an Odroid XU4 that I just installed Diet Pi on last week with no troubles.

Now I have a C2 that I am trying to set up the same way, except with eMMc instead of SD.

It boots fine with the image, down loads and unpacks.

I go through the menus for set, it does it’s thing, but then screen goes blank and LED stops blinking.

I do see error messages related to a bad symbolic links that gets deleted. The link is referencing:

/lib/modules/3.1.14.79+/sources
and
/lib/modules/3.1.14.79+/build

I assume the binarys are already there so they don’t matter.

After the screen goes out, it will no longer boot until I put the image back on it again.

Any debug info to look for?

Interestingly… I tried installing to an SD card and it worked fine.
Not sure what’s up. Perhaps I will try in making an image of the install and writing that to eMMC.
The only trouble is my SD card is 32GB and the eMMC is only 16, so I need to shrink an image to fit.

Exactly the same problem for me. And from what I saw on other posts we’re not alone.

I have an SD card that fits the size of my eMMC : 16gb.
So I did what you suggested : install clean on SD, then keep this image to write on eMMC.

It doesn’t work. It doesn’t get fooled by this technique. It boots until pages of errors and stall. Next time I reboot, nothing happens. Just like when you install directly on it.

It surely is a shame as eMMC is quite faster. Hope there’ll be a fix soon enough.

Hi guys,

I run 8GB & 128GB EMMC’s on the C2 with latest image. I’am yet to experience the issues you are describing.

Can you confirm which PSU’s you are using for the C2?

Also, how are you writing the image to SD/EMMC? (eg: win32diskimager).

If you are using win32diskimager, please try formatting the SD/EMMC before writing the DietPi image, using this program with these settings:

  • Format type = Quick
  • Format size adjustment ON

Hi,
I’m using v139 for the C2.
PSU: output : 5V / 2000ma. Bought on amazon.
I usually use my macbook to erase and format the card (forget why, but it’s easier with disk tools). I format to fat just to get rid of the partitions.
Then I use win32diskimager on a pc to write the image on the EMMC (and/or SDCARD).

I will try with sdformater then, and let you know.

I would add, the ubuntu release works like a charm on the eMMC.
But don’t meet my needs (missing audio passthrough).
Not Dietpi.

:slight_smile:

I would recommend booting up C2 hooked up directly to a monitor for those that are running into a black screen or connection failed for SSH

I had posted about this problem earlier. I had done a successful SDHC install but had the eMMC fail. Coping the /boot partition from the SDHC to the eMMC allowed it to boot one time. I could install other software and then it would fail on reboot. Just for heck of it, I re-copied the img to the eMMC and set the auto-install to true. I did this one as a headless install, just power and the network cable. Low and behold it succeed. I can ssh into the C2, something I could not do when I had it attached to a monitor. It is all very strange, but I now seem to have a functioning DietPi C2 running off of eMMC. I have installed OpenSSH, Samba, miniDNLA & MC. All good.

hmm.

ok, so first I tried formatting differently with the SDformatter.
Then I tried what dsfraser said. Especially the “auto_install=1” in the dietpi.txt on the boot partition.

When rebooted, the screen went blank again.
I then copied a custom boot partition with boot.ini and dietpi.txt modified (screen resolution set to 0, and other options).
Then it booted correctly.
I had to install software again but everything is fine now.
Strange.
So there seems to be some sort of boot partition problem, in my opinion.
I’'ll try to upload my boot partition and the img separately. I only installed MATE, Kodi, audio driver and screen resolution to 720p, for now.

By this did you mean a simple copy the files in /boot, or, copy of the physical boot partition?

EDIT: Working on a new image, seems we had a corrupt 1st parition, will let you know when its ready for testing:
https://github.com/Fourdee/DietPi/issues/719#issuecomment-277533451

Ok new image is now available for testing.

Please can you guys re-test your installations with the new image and let us know results?
https://dietpi.com/downloads/images/

Sorry I meant copying the files from the boot partition.

Ok, I’ll try that as soon as I can.
Thkx

Hi,
so I tried the new image.
At the end, same result.
But:
on the way of the first boot, when installing the first data, my ssh connection stopped when at :


Setting up libcurl3-gnutls:arm64 (7.38.0-4+deb8u5) …
Setting up apt-transport-https (1.0.9.8.4) …
Processing triggers for libc-bin (2.19-18+deb8u7) …

I then started another ssh to install MATE & Kodi.

Everything went good. It rebooted. And still ok, but in command line.
Then I installed Audio drivers/lirc and rebooted.
Still ok.

Then I configured it to boot on MATE.
And that’s when it crash at reboot. Blank screen.

Hope that helps.

Thanks for testing. I ran a similar test on the image installing a shed loads of programs, runs a treat for me after reboot on 128GB EMMC.


Ok, some questions:

  • No heartbeat after install MATE and rebooting? (flashing blue LED)
  • Do you have the same issues with SD card, or, only with EMMC?
  • Which SD card reader are you using?
  • Have you tried a different EMMC > SD adapter, and, SD card reader when writing?

Lets try another method for image write on EMMC:

Can you also link the PSU you purchased on Amazon if possible?

I went too fast on this one.
It seems the networks disconnection would be on my side.

I tried again for 2-3 times. At the end : no problem. Each time, I had a problem with my resolution, disconnecting network, wanted to install everything at once etc. (not a good reference for debug, then. My bad).

The last time, I simply installed things step by step, trying to make it clean.
Much better. For the first time, tho, I installed only MATE for the first round. Usually I installed MATE & Kodi at once. Maybe that’s a game changer? (don’t see why it could be).

At the end, I rebooted 4 times, just to check if it didn’t stall again.

So, good work for this new image : that’s a success.

To answer your previous questions and for debug :

_Ok, some questions:

  1. No heartbeat after install MATE and rebooting? (flashing blue LED)
  2. Do you have the same issues with SD card, or, only with EMMC?
  3. Which SD card reader are you using?
  4. Have you tried a different EMMC > SD adapter, and, SD card reader when writing?[/quote]_

1: Heartbeats were on
2: no issue whatsoever on SD card: smoother.
3: it’s a sd card adapter usbToSDcard like the one you get with your DSLR
4: no, I only got one of each.

I always use win32diskimage to write the img, and SDformater to format them.

I can add one more positive for the new image. I had been able to get the 139 image kind of running on eMMC. I didn’t notice at the time but the ‘df’ command would just hang, needed a ‘ctrl c’ to break out of it. Also ‘shutdown -h now’ would not do anything, rather strange. With the new 143 image everything seems to work as expected. Just curious as to what the issue was with the older image, and why it only seemed to affect eMMC and not a SDHC card?

Thank-you for the fix.