Odroid C2 cec-client can't find any devices

Did anybody manage to use HDMI CEC with the Odroid C2?

Whenever I run ‘cec-client -l’ I get the following result:

libCEC version: 4.0.1, compiled on Linux-3.16.0-4-armmp-lpae ... , features: P8_USB, DRM, P8_detect, randr
Found devices: NONE

I know that my TV and my HDMI cable can manage CEC, because I sucessfully used it with a Raspberry Pi.
If anybody could offer guidance that would be really kind!

EDIT: I don’t have any /dev/CEC, so I guess it’s missing from the kernel? Or am I missing something?


Did you try: https://forum.odroid.com/viewtopic.php?f=52&t=2973

Generally the kernel support it, based on this commit from 2016: https://github.com/LibreELEC/LibreELEC.tv/pull/328/commits/5c62ee8d3ebfcce18b14b35977417c14e63a8079

At first I’ve tried to simply apt-get libcec-dev and cec-utils, it did not work.
Then I’ve tried the guide you just linked, and I have the exact same result.

I’ve updated from DietPi v6.14 to v6.20, maybe that’s what caused the issue?
I did not try CEC while running v6.14, so I’m not sure about that.

Thanks for your feedback.

Hmm, I just read the note beneath the install instructions. So yeah, if the APT package itself does not work, but the custom build (which is what the guide instructs) does, you would need to block APT updates for this package: apt-mark hold libcec*

If both don’t work, we have to investigate. Perhaps we find something among opened or closed DietPi GitHub issues: https://github.com/Fourdee/DietPi/issues