Octoprint + mjpg-streamer ffmpeg error

Good night,

I have an onl rasp pi2 and i decided to try octoprint, i made a fresh installation and everything seems to be working except the camera. I did a bit of reasearch and i found that for the camera to work i will also need to install mjpg-streamer, the problem is that with octoprint installed i have an error installing ffmpeg.

I leave the error i am getting in the extra details.

Thank you

Creating a bug report/issue

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
    bookworm 0
  • Kernel version | uname -a
    Linux DietPi 6.1.21-v7+ #1642 SMP Mon Apr 3 17:20:52 BST 2023 armv7l GNU/Linux
  • Architecture | dpkg --print-architecture
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
    RPi 2 Model B (armv7l)
  • Power supply used | (EG: 5V 1A RAVpower)
    5V - 2A
  • SD card used | (EG: SanDisk ultra)
    Sandisk ultra

Additional Information (if applicable)

  • Software title | Octoprint \ mjpg-streamer
  • Fresh installation

Steps to reproduce

Expected behaviour

Actual behaviour

Extra details

APT install ffmpeg                                                                                 

 Command: apt-get -y --allow-change-held-packages install ffmpeg                                 
Exit code: 100                                                                                  
  DietPi version: v8.19.1 (MichaIng/master) | HW_MODEL: 2 | HW_ARCH: 2 | DISTRO: 7                
 - Error log:                                                                                      

Reading package lists...                                                                           

Building dependency tree...                                                                        
Reading state information...                                                                       
Some packages could not be installed. This may mean that you have                                  
requested an impossible situation or if you are using the unstable                                 
distribution that some required packages have not yet been created                                 
or been moved out of Incoming.                                                                     
The following information may help to resolve the situation:                                       
The following packages have unmet dependencies:                                                    
 ffmpeg : Depends: libavcodec58 (= 8:4.3.6-0+deb11u1+rpt2)                                         
          Depends: libavfilter7 (= 8:4.3.6-0+deb11u1+rpt2)                                         
 libavdevice58 : Depends: libavcodec58 (= 8:4.3.6-0+deb11u1+rpt2)                                  
                 Depends: libavfilter7 (= 8:4.3.6-0+deb11u1+rpt2)                                  
 libavformat58 : Depends: libavcodec58 (= 8:4.3.6-0+deb11u1+rpt2)                                  
                 Depends: libsrt1.4-gnutls (>= 1.4.2) but it is not installable

Truthfully…the absolute best way to run octoprint is in a docker container…I have it running like a boss on my AtomicPI running my Anet A8 3d printer (of which I need to print more)

This way it’s a self contained instance, and doesn’t rely upon the OS’s installed packages…if it can’t pull ffmpeg due some sort of dependency failure…the docker package will already have it installed

Heck I even installed octoprint on an old cellphone I had, used the USB-OTG port to run it (it was on a easythreed X1) using octo4a

Yes, there is a known challenge for ffmpeg. This might be a workaround for time being. The following packages have been kept back: ffmpeg - #28 by Joulinar

1 Like

Thank you for the feedback

My linux capabilities are still very low, i tried docker recently but i had a lot of problems running nextcloud when i tried to change the database location.

I will give it another try with octoprint.

Thanks again