OctoPi camera Stream

Hi, I am successfully running OctoPi. I would like to get the camera streaming setup but the settings are not pre-filled in on the OctoPi settings page.

On the OctoPrint https://octopi.octoprint.org/ it states

If a USB webcam or the Raspberry Pi camera is detected, MJPG-streamer will be started automatically as webcam server. OctoPrint on OctoPi ships with correctly configured stream and snapshot URLs pointing at it. If necessary, you can reach it under http://octopi.local/webcam/?action=stream and SSL respectively, or directly on its configured port 8080: http://octopi.local:8080/?action=stream.

Does OctoPi on DietPi come configured to stream the camera, if so, what is the stream URL.
thank you
Keith Ellis

Actually, someone has just pointed me to this page. Is this something that DietPi could setup automatically?

https://github.com/foosel/OctoPrint/wiki/Setup-on-a-Raspberry-Pi-running-Raspbian#webcam

Regards,
Keith Ellis

Octopi stream is the IP address of the server

http://LOCAL.LAN.IP.ADDRESS:8080/?action=stream for stream

http://LOCAL.LAN.IP.ADDRESS:8080/?action=snapshot

I believe you can change the port it goes out on as well…if you log into octopi as admin, there is a server config tab at the top where you can check/edit/tweak the video capture…I use a Logitech C270 USB as my capture device

Here are a few of my timelapses from octoprint running on a dual core laptop with 2gigs ram

GmSlBxnnq0Q

0PrDsTbiH5k

Yes, that is what I want, but DietPi does not install by default. Can this be an option during the DietPi OctoPi install?

I have to manually start mine each time I reboot…I will post up the command I put in (but have to copy/paste each time) to get it to start

nohup sudo /home/user1/mjpg-streamer/mjpg-streamer-experimental/mjpg_streamer -i "/home/user1/mjpg-streamer/mjpg-streamer-experimental/input_uvc.so -y -br auto -cb auto -wb auto -gain auto -q 100 -r SXGA" -o "/home/user1/mjpg-streamer/mjpg-streamer-experimental/output_http.so" &

I am using a Logitech C270 USB camera on a xubuntu on a desktop install (not sure if that matters)

I suppose I could add that command to the end of the /etc/init.d/octoprint startup script instead of /etc/rc.local

Just did a list of my files in /home/user1/mjpg-streamer/mjpg-streamer-experimental/ I have a file called output_http.so -p 8080 chmodded as 744 under user1:user1 so maybe that is the file that tells it what port to output the http stream on…so create a file with whatever port you want and try that

There are some dependencies that need to be met first…not installed “automatically” I believe…check your octoprint install directory
https://www.acmesystems.it/video_streaming

just added that code to the end of the /etc/init.d/octoprint file, it does work…it starts, however it will not kill it if I do service octoprint restart…so I either manually have to find the pid and kill it then service octoprint restart or reboot the machine

I also changed the SXGA to just XGA, the resolution in video streaming was so laggy in the ultra high resolution…much more snappy now

I have a feeleing you did not install OctoPi using DietPi. is this correct?

Yes…it’s on an old busted screen dual core laptop with 2gigs RAM and running xubuntu
I followed this walkthru
https://github.com/foosel/OctoPrint/wiki/Setup-on-a-Raspberry-Pi-running-Raspbian
I added a sudoer user called user1 using this walkthru
https://www.digitalocean.com/community/tutorials/how-to-create-a-sudo-user-on-ubuntu-quickstart

Might be easier to install python with dietpi install script