Nvidia Drivers for T400 not recognizing the card

Creating a bug report/issue

Required Information

  • DietPi version |
    G_DIETPI_VERSION_CORE=8
    G_DIETPI_VERSION_SUB=6
    G_DIETPI_VERSION_RC=1
    G_GITBRANCH=‘master’
    G_GITOWNER=‘MichaIng’
    G_LIVE_PATCH_STATUS[0]=‘applied’
    G_LIVE_PATCH_STATUS[1]=‘not applied’
  • Distro version | bullseye
  • Kernel version | Linux plex 5.18.0-0.bpo.1-amd64 #1 SMP PREEMPT_DYNAMIC Debian 5.18.2-1~bpo11+1 (2022-06-14) x86_64 GNU/Linux
  • SBC model | Native PC (x86_64)

Additional Information (if applicable)

  • Software title | Nvidia Drivers
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | a2c62f05-1c65-46fe-8569-565f86a4a45b

Steps to reproduce

  1. Get and install Nvidia T400 2GB video card
  2. wget nvidia drivers from Linux x64 (AMD64/EM64T) Display Driver | 515.57 | Linux 64-bit | NVIDIA
  3. chmod +x the .run file
  4. execute the run file as sudo
  5. run nvidia-smi to verify the install

Expected behaviour

  • nvidia-smi should recognize the video card and show stats about the card

Actual behaviour

  • nvidia-smi cannot find any compatible hardware

I also have a P400 and a GTX 1660, both of these cards show up with full details prior to installing the drivers through lspci, but this card always shows up as
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1fb2 (rev a1)

Nouveau drivers are blacklisted in /etc/modprobe.d/blacklist-nouveau.conf

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

Nouveau is blacklisted in grub also with the line below

GRUB_CMDLINE_LINUX_DEFAULT="quiet rd.driver.blacklist=grub.nouveau rcutree.rcu_idle_gp_delay=1"

I’ve uninstalled everything with nvidia and tried again with no luck.
I’ve also tried installing the drivers through apt, same issue there.