NTFS write speed

I know that ext4 (for example) is better for linux, nevertheless I try out NTFS with my external WD Red via USB 3.
Read is ok with me (over 100MB/s in general), but write is only 16MB/s, is that normal?

In this comparison chart Tuxera NTFS drivers has write speed 92MB/s for nomal HDD with USB3!?
https://www.alexwhittemore.com/ntfs-on-macos-paragon-or-tuxera-round-two-high-sierra/
(…but it’s on MacOs, if this makes much difference)

Does anyone have tried Paragon NTFS drivers or are any other NTFS drivers than the normal Dietpi built-in ones.
I tried to install the Paragon free NTFS drivers, but I got an error message :-/

What NTFS driver is being used?

Have you tried the ntfs-3g one?

sudo apt-get install ntfs-3g

I wonder what the bottleneck could be…have you looked at CPU frequency or usage when trying to write to the drive…if the scaling drops it also drops the speed of IO to the device

Thanks for the recommendation, but this driver is already installed by default.

I’ve tried again to install the Paragon driver, but still don’t know how to fix this:

looks like the driver install is expecting a config.log file

To ensure all is working fine, did you tried using ext4 file system? Just to compare speed during write.

Do you might know, where this log file should be located?
Already tried to make a new “config.log” file in the same directory with all the rights (root, 777).

I already have my files on my ntfs formatted drive, would take to much time to copy everything somewhere else, just to format to ext4.

can you share where you got the install.sh from? Probably we can have a look. Maybe we could find out where the file would need to be placed.

I got the driver from the Paragon website, the direct download link is:
https://dl.paragon-software.com/free/Paragon_NTFS_for_Linux_driver_Retail_Express_lke_9.7.0.tar.gz

I had a look in the install.sh too, I found this:

if ! ./configure --with-modulename="$modulename" >> "$LP/paragon-ufsd-install.log" 2>&1; then
fancy 'Configure log'
cat "config.log" >> "$LP/paragon-ufsd-install.log"
fancy 'Configure log'

Don’t know what this variable $LP/ means…

$LP is defined at the beginning of the script. It should be the current directory. Anyway, the issue is following command

cat "config.log"

But this you could tweak, be changing cat “config.log” into cat “/file/location/config.log”. Means you could specify the exact location of the config.log file you created.

Thanks Joulinar, the error with the log file is gone now.

The other one still persists:
Searching and removing previously installed UFSD driver in /lib/modules/4.4.192-rockchip64/
Preparing to install
Error: Can’t prepare driver configuration

The folder /lib/modules/4.4.192-rockchip64/ exists, and I was logged in as root when I started the install script from Paragon.
The created config.log is empty.

Wondering how good these Paragon NTFS drivers really are and if this might fix my problem, when I see how bad the install script is already written… :stuck_out_tongue:

you would need to have a look into paragon-ufsd-install.log, to check what the issue is about.

Anyway i would recommend to contact paragon support for you issue. Maybe the driver can’t be installed on your device??

The logfile paragon-ufsd-install.log doesn’t exist.

Thanks for having a look.
I try my luck in the Paragon support forum.

ok, pls keep us posted how it goes

I got no answer in the Paragon forum, but I’ve updated the NTFS-3G driver.
The one which comes with DietPi is outdated, I think it was from 2015, the newest is from 2017.
I would say the write speed is faster now, read speed was good before anyway.
Nevertheless I get the the same results concerning the low speed, when running the DietPi Benchmark tool… but don’t know, I would say its better now.
Might switch to ext4 in the future, we’ll see.

probably you can share what you have done to update the driver. Maybe there are other, who like to know what you have done :wink:

Sure, I followed this tutorial:
https://www.htpcguides.com/install-latest-ntfs-3g-source-debian-ubuntu/

ok so basically you compiled your own one. What version do you have now? On my RPi3B+, I get the following if I install ntfs-3g from apt repository.

root@DietPi3:~# ntfs-3g --version
ntfs-3g 2017.3.23AR.3 integrated FUSE 28
root@DietPi3:~#