nordvpn + torrent on headless rpi3

I have a Raspberry Pi3 running DietPi as a headless server.
I have tried to get Deluge and rtorrent+rutorrent working but nothing gets downloaded despite being connected a p2p friendly server (A German one). So my idea is to have a light webserver on the Pi3 offering a web interface to the torrent program. I understand that this is only possible when using a Socks5 proxy and that rtorrent doesn’t support Socks5, am I right?
What would be a good setup to achieve the aboven (that doesn’t imply installing X Windows?

Strange that there are reported so many issues with torrent downloads via NordVPN since I find so many reports that it is indeed a very recommended VPN provider for P2P/torrent purpose. Perhaps I have to setup a test account any try myself, although the instructions from NordVPN are very clear and there is not much that one can do wrong, especially if with disabled VPN download+upload works.

Yeah rTorrent does not provide internal proxy support so this needs to be enabled externally. However SOCKS5 should not be required, just an enhancement for torrenting. Deluge however supports this, so I suggest you try with this first:

Even with VPN enabled you can always access the web UI from local network by using the local IP/hostname of the server. Only when accessing externally a dedicated proxy to bypass the VPN. With rTorrent (ruTorrent) there is already a webserver that provides ruTorrent access. Only Deluge has it’s own internal web application.
But most properly you don’t want the system to communicate to WAN outside of the VPN. At least I would recommend this and open the web UIs only to the local network?

Thanks a lot for your fast reply and helpful insights.

I could swear I had rtorrent working fine some months ago on a previous installation (that SD card is truly dead now)

I tried deluge 2 weeks ago but despite setting the socks5 proxy I was having the same problem; downloads stayed at 0Kb downloaded

And yes you are right, I don’t want to access the webif from the WAN.
The only other purpose this raspberry pi serves (and it servers well) is to act as a web gateway, so when I change the default gateway in LAN clients from the router to the raspberry pi, then thanks to iptables the traffic is routed through nordvpn (and that works like a charm)
So if I get deluge working, then I can uninstall the web server as deluge doesn’t use one?

I will try Deluge with the guide you pointed out and report back

Tried deluge and it works with sock5 but another set of problems.
When I try to connect from a LAN linux with the Deluge client:

tail -n 12 /mnt/dietpi_userdata/deluge/.config/deluge/deluged.log

BadLoginError: Password does not match
root@Brexit:/mnt/dietpi_userdata/deluge/.config/deluge# tail -n 12 deluged.log 
  File "/usr/lib/python2.7/dist-packages/deluge/core/", line 262, in dispatch
    ret = component.get("AuthManager").authorize(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/core/", line 95, in authorize
    raise BadLoginError("Password does not match")
BadLoginError: Password does not match
Password does not match
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/deluge/core/", line 262, in dispatch
    ret = component.get("AuthManager").authorize(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/deluge/core/", line 95, in authorize
    raise BadLoginError("Password does not match")
BadLoginError: Password does not match

I tried to connect as root/dietpi . Is it supposed to be a different user for the client connection?

Does it work if you login via web interface and password dietpi?
Did you ever changed your global software password e.g. on first boot?

Yes it works
And yes, I changed the global password directly in the .txt file (not during the installation)
but it seems like dietpi is still the default.
I have changed the deluge password in the webif (preferences, interface)

You did follow this instructions to enable deluge client login?

If changing the password via deluge web UI does still not allow client login, then perhaps some special characters are not handled well by deluge. Otherwise strange then that web UI login works.

Note that the global password inside dietpi.txt is only used on first run setup. It is then stored encrypted on the root file system. To change it afterwards you need to change via dietpi-config. So yours is still dietpi then.

Thanks, I have changed strategy.
Dug out an old Raspberry Pi 1 (model B) and set it up with nordvpn and routing all traffic through the VPN (thanks to iptables).

#Enable IP Forwarding 
sudo sysctl -w net.ipv4.ip_forward=1
sudo iptables -t nat -A POSTROUTING -o tun0 -j MASQUERADE

#These rules will redirect the kernel to accept packets coming from the subnet, and forward them onto the tun0 #interface.
sudo iptables -I FORWARD -o tun0 -s -j ACCEPT
sudo iptables -I INPUT -s -j ACCEPT

Did a new installation of rtorrent on the Raspberry Pi 3 but this time with no vpn or iptables and instead set the default gateway to the ip of the Raspberry pi 1

I verify that the Raspbery pi 3 has a vpned public ip with

dig TXT +short

then launch rtorrent which works but I would say it is a bit slow

How could I speed it up since it has no socks5 proxy support?

Yes I did, but it never worked, I tried all sort of passwords, I think it is something different but I have given up on deluge for now