node-red installed but doesn't exist?


I am running DietPi v6.22 Pi Zero W and installed the optimized version of Node-Red through DietPi-Software. The install went apparently went OK and when the system rebooted it showed that the node-red service started. However when I run systemctl --failed it says that node-red isn’t running. When I run systemctl status node-red the message I get is that the /usr/local/bin/node-red file doesn’t exist. When I checked, sure enough it’s not there. However DietPi-Software indicates that it is installed along with node.js (which apparently also doesn’t exist when I run node -v to check). Ironically, a node-red directory in dietpi-userdata does exist, which means that something was installed. Finally, it goes without saying that when I tried to run node-red via the web (port 1880) I was unable to connect.

Is this package via DietPi-Software somehow broken? Is there another (perhaps better) way to install node-red? For instance, should I use the method suggested here by baz123?

Thank in advance for any help.


This is an update to my problem. Because the node-red installation first needs NodeJS to be installed, I ran the following:

dietpi-software install 9

This was the result:

 Mode: Installing Node.js: javascript runtime

[  OK  ] DietPi-Software | Connection test:
URL transformed to HTTPS due to an HSTS policy
--2019-05-03 16:55:27--
Resolving (,,, ...
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1943 (1.9K) [text/plain]
Saving to: ‘’             100%[===========================================>]   1.90K  --.-KB/s    in 0.003s  

2019-05-03 16:55:28 (659 KB/s) - ‘’ saved [1943/1943]

Node Linux Installer by
Running as Root User
Get Latest Version Number...
Downloading latest stable Version ...

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
ERROR: Couldn't extract tar

So apparently Node-Red was not installed because NodeJS was unable to install since the file is invalid. However, my system still says that both Node-Red and Node are installed:

I used the uninstall software view since it shows both Node-Red and NodeJS together in one place.

So it looks like there are two problems:

  1. NodeJS can’t be installed because of a bad file or file type
  2. DietPi shows software as installed even though they are not

Anyway around this?

Hey guys. Jep it is due to Node.js dropped support for ARMv6 with latest Node 12 but didn’t adjust their installer accordingly (yet). If you have an ARMv6 device see here for solution:

We fixed this for DietPi v6.23. I hope the official Node installer itself will be fixed as well soon so that we can skip the hacky workaround.