No Wi-Fi hardware found?

It might be just me but trying out a new install image on a RPi 3B v1.2 and getting no where fast.

The config tool reports ‘No Wireless Hardware Found’

I’ve goofed about with dietpi.txt and dietpi-wifi.txt but the config tool shows

Eth Avail [Off] Con
Wifi Not Found [On] DisCon
Onboard Wifi [On]

Any tips? I do have WiFi chip… don’t I ?

did you switched Onboard Wifi [On] to On manually? Did you reboot your system afterwards?

I enabled wifi / disabled eth in dietpi.txt and added ssd/key in dietpi-wifi.txt before booting

When it didnt work I tried disabling it in config tool then re-enabling it

Notice at boot a wpa supplicant error 1

Guess what? Works fine with a dongle! What gives!? Do I have a duff baord?

can you have a look pls if there is a way to check onboard wifi

root@DietPi:~# modprobe -r brcmfmac
root@DietPi:~# modprobe brcmfmac
root@DietPi:~# dmesg | grep mmc1
[3.401335] mmc1: error -110 whilst initialising SDIO card

root@DietPi:~# ls -al /lib/firmware/brcm | grep brcmfmac
-rw-r--r--  1 root root    1121 Jan 14 20:35 brcmfmac43430-sdio.txt
-rw-r--r--  1 root root  382455 Jan 14 20:35 brcmfmac43430a0-sdio.bin

Think I have a duff board :frowning:

Also; tried on rasbian or raspios or whatever it’s now called. I get the same message about SDIO card error?

Hmm when “Onboard WiFi” is set to “On” and you rebooted, it should work. No need to manually load kernel modules, this is/should be done automatically. If it doesn’t work, and doesn’t either on Raspberry Pi OS, probably there is a hardware issue :frowning:? But also check whether e.g. PSU is insufficient or cable bad quality. E.g. dmesg and vcgencmd get_throttled may report kernel/voltage errors (the latter reports “0x0” if everything is fine).

Ah, wasn’t there a case with some RPi 3+ that WiFi didn’t work when Bluetooth is disabled, or the other way round. I think it was fixed and on RPi OS Bluetooth isn’t disabled by default, but to rule it out, aside of the above, you could try to enable it. It is sufficient to remove or comment the “dtoverlay=disable-bt” line im /boot/config.txt and reboot.