No subtitles on Kodi : Dietpi v8.21.1 Kodi 2:20.0+dfsg-2

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8 G_DIETPI_VERSION_SUB=21 G_DIETPI_VERSION_RC=1 G_GITBRANCH='master' G_GITOWNER='MichaIng'
  • Distro version | bookworn1
  • Kernel version | Linux kodizero 6.1.21-v7+ #1642 SMP Mon Apr 3 17:20:52 BST 2023 armv7l GNU/Linux
  • Architecture | armhf
  • SBC model | RPi 2 Model B (armv7l)
  • Power supply used | Official Raspberry Pi power supply
  • SD card used | (16GB SanDisk ultra)

Additional Information (if applicable)

  • Software title | Kodi
  • Was the software title installed freshly or updated/migrated? Freshly
  • Can this issue be replicated on a fresh installation of DietPi? Yes

Steps to reproduce

  1. Find an .mkv file with embedded subtitles. Find an .mp4 file with external .srt subtitles. Test those subtitles work on VLC on a desktop PC. Test those subtitles work on LibreElec on Raspberry Pi.
  2. Fresh install of DietPi. As root, install Kodi from the software menu. (Kodi runs from framebuffer, no desktop installed)
  3. Add the known-good .mkv , .mp4 and .srt to the video library
  4. Play the video files. Enable subtitles.
  5. No subtitles are shown, neither for the embedded subtitles in the .mkv nor for the external .srt subtitles for the .mp4.

Expected behaviour

  • Subtitles should be shown

Actual behaviour

  • Subtitles are not shown

Extra details

‘kodi --version’ reports:
Kodi from Debian Media Center 20.0 Debian package version: 2:20.0+dfsg-2
Copyright (C) 2005-2021 Team Kodi from Debian - http://kodi.tv

I am partially deaf so rely on subtitles. I have a large library of subtitled video files which play back OK on VLC under Linux and Windows, LibreElec on Raspberry Pi, and Kodi 20 sideloaded onto Amazon Fire TV Stick. It’s not the files and it’s not a problem with understanding how to turn subtitles on.

did you already tried to install subtitle addon? Solved - How to Get Kodi Subtitles in 2023 - MiniTool MovieMaker

@Joulinar I do happen to have OpenSubtitles.org addon installed, but that is not relevent to my problem.

The problem is, subtitles that have already been downloaded or are already embedded into the video file, do not appear on the screen, even after subtitles have been enabled.

Thanks for trying to help, though.

Nope, Kodi runs via KMS/DRM/GBM.

Not sure whether it still applies to Kodi 20, but the linked article indicates that Kodi indeed does not support subtitles OOTB but requires an add-on for this. It seems to contradict the fact that you “enabled” subtitles (is there a toggle in settings?), but at least worth a test.

If really subtitles are supposed to with OOTB with this Kodi version, it is probably a topic for the RPi forum, as we use the Kodi build from the RPi repo. But probably we have some Kodi cracks here as well (I’m none).

EDIT: Ah nope, I misunderstood, it indeed states that there is builtin subtitle support, and the addon only for generating/editing them.

1 Like

Has anyone managed to get subtitles visible with Kodi on DietPi 8.21 under KMS/DRM/GDM (i.e. no desktop) please?

I need to determine whether this is everyone, or just me. Thanks.

If you have a spare SD card, you could try to crosscheck using plain Raspberry Pi OS.