no more Firefox nor Chromium running

I have the latest Diepi version running on a Sparky board.

My problem is that I can’t open firefox anymore under LXDE desktop environnement (I get a crash reporter window)

When I run the Web Chromium browser I have a blank windows !!!

I remember that in some prevoious version of Dietpi, firefox was running flawlessly.

Do you remember from which version you upgraded? AFAIK we did not change something about the Firefox or Chromium install.
You could try to reinstall the Firefox package (to start with this): apt install --reinstall firefox-esr

Sorry I do not remenber …

I have re-installed from scratch the last version but the problem is still there for Web Chromium and Firefox as well.

I am using the Web GUI Image,with V6.24.1 Dietpi version running.

I have manually installed the chromium version 65.0.3325.181 Built on Ubuntu, running on Debian 9.9 (32bits)
Chromium is now running.

It seem that more recent chromium version does not work properly because they need the libc6 version to be above 2.28 version !

Firefox is still not running (even after an : apt install --reinstall firefox-esr)

Ah that is helpful info. Indeed Debian Stretch only ships libc6 2.24:
I just wonder that the Chromium package from Debian Stretch that we install of course does not require a higher version then available, actually 2.17 at max, as you can see:

Does TinkerOS ship an own Chromium package that is not compatible with Debian Stretch? That would be clear bug, since TinkerOS AFAIK comes with Debian Stretch basis.

Please paste: apt policy chromium

result of : apt policy chromium

Installé : 72.0.3626.122-1~deb9u1
Candidat : 72.0.3626.122-1~deb9u1
Table de version :
*** 72.0.3626.122-1~deb9u1 500
500 stretch/updates/main armhf Packages
100 /var/lib/dpkg/status
70.0.3538.110-1~deb9u1 500
500 stretch/main armhf Packages

As additionnal Info : When I run Chromium, I have the following warning message
“Your profile cannot be used, because it comes from a more recent version of chromium”
" Some features could be unavailable. Please specify another profile directory or use a more recent version of chromium"

Okay so your chromium is indeed the one from Debian repo. That it should not require a newer libc6 version then what the APT package list. Such repo bugs are veeeeery rare with Debian and especially with such prominent packages like Chromium, practically impossible.

So not sure why you needed to downgrade then :thinking:. Perhaps TinkerOS needs to adjustment then, a driver update or something, not sure. Where did you get the info about libc6 from, actually?

Since you downgraded, the error is just expected. Currently not sure where the profile dir of Chromium is, perhaps inside /root or /root/.config. You could try to simply remove all Chromium related directories from there, of course settings and such would be lost.

I have got the libc6 info when I first installed the very last version of Chromium (from debian) … I got an error message
regarding the libc6 version needed to be 2.28 or above (cf my previous post => libc6 version to be upgrade ??)

so I looked for a chromium version released within the period the actual libc6 version was available… and I picked it :smiley:

(by the way could you give us back the possibility to set the framebuffer at 32 bit (cf my other post) ) thank you

About framebuffer:

About Chromium: The error appeared during install (testing it right now) or when opening Chromium the first time?

Thanks for the anwser about bitdeph

The error with chromium (and also with Firefox) appears when opening the app for the first time

Okay thanks, will try to replicate.

Kiosk mode works well. Will try to start from desktop later.


Any news about this issue?

I’ve just installed DietPi on my old RPI 1 B+ hoping for a good performance because even Raspbian lite was too slow. Everything seemed to be Ok but when I ran FireFox for the first time it crashed. I found no solution and after reading quite a few posts finally got to this one.

Is there any solution? I cannot use DietPi without a browser…


I’d also like to know if something has been found regarding this issue.

I just put dietpi on my Rpi Zero W for Pi-hole and when attempting to load up Firefox-ESR it just tries really hard and crashes.

Note, my pi is at 100% cpu when doing this.



I am having the same issue.

I installed Dietpi on a RPi 1and neither Firefox nor Chromium is working.

I am also struggling to get the Kiosk working.