(No longer supported) OPi Zero wifi v6.1


Not been able to get this to work whereas it worked fine with earlier versions.

It looks like the system does not see the hardware. Got it connected with a USB wifi adaptor but would be better to have the onboard wifi working.

Anyone got this going?


I just tested it with the OPi0 512Mb and managed got the Wifi it activated, scanned for networks and connected without any issues.
Maybe it is a lose solder? These boards can get really hot sometimes!

Tried this on both my OPi zeros here - same on both., the hardware not found.

Are you running DietPi 6.1?


yep, I´m on 6.1.

Two OPi zeros - no wifi on v6.1

Tried a new install of v159 - wifi working.


I can confirm…same issue here!

Wifi not working with Orange-Pi zero…seems to be a driver issue with the “exotic” wifi chip…(at least that’s why Armbian isn’t working either…)



The situation is not likely to change as DietPi is no longer supporting the Orange Pi devices. If wifi is essential then I can confirm that I had it working with a cheap USB wifi adaptor on v6.1.


Saw what…no longer supporting Orange Pi devices???

What the heck?!?!?

i have the same issue …

Wifi works in old’s Dietpi Rom? it’s a problem, the new Dietpi works very well! and light, but with this problem … i go to searcg for another distros for use wifi

Locking. We no longer support this device or provide an image for it.