No longer booting from SSD

Maybe you can help me once again.

Couple of weeks ago I asked for help on setting up my Raspberry Pi 3b with an external SSD drive. With some help from here I got it working as webserver. WordPress complained about a missing component (bcmath), so I installed that with sudo install php-bcmath (I think this was the command, but not sure). After that installed I did a reboot and that was the start of problems. The Pi didn’t boot anymore. Tried placing the sd-card and boot from there. That did work. Wa happy and hoping it would be a matter of minutes before everything would work again.

The Pi only boots with SD card installed, so I first tried to see if the OTP switch was set, and in dietpi-config I see that USB support was set to ‘On’.

Then I did a check to see if the SSD drive could been ‘seen’ from the Pi it self with lsusb, and that also was the case.

root@WebServ:~# lsusb
Bus 001 Device 004: ID 1058:2642 Western Digital Technologies, Inc. Game Drive
Bus 001 Device 003: ID 0424:ec00 Microchip Technology, Inc. (formerly SMSC) SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Microchip Technology, Inc. (formerly SMSC) SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

(btw when using a powered USB-hub it doesn’t work)

So, next I tried to once again boot from USB, and waited for about 40 -45 minutes, but to no avail.

Would #3 on this post be able fix this?

Are you able to connect a screen? Otherwise it would be quite hard to find out what the issue is.

(btw when using a powered USB-hub it doesn’t work)

But this is the only way it gonna work reliably. Without an external power supply, 2.5" drives (including SSDs) usually draw too much power from the RPi’s USB port. Especially during boot, where you have a power usage peak already, the USB drive may then simply remain unconnected/undetected. And you don’t want to loose your data due to root drive crashes. So you need to get it working/detected as external drive when its attached via powered USB hub or enclosure with a dedicated power supply first, before it makes sense to debug booting from it.


sudo install php-bcmath

This is btw how users install PHP8.0 (now PHP8.1) on Stretch systems with Ondrej’s PHP repo, as Wordpress, Nextcloud and others complain about modules they don’t really require. sudo install php7.3-bcmath would be fine, but the above as meta package pulls the moving target PHP version. Hence I won’t ever again add Ondrej’s PHP repo to keep supporting software on old distro versions :wink:. This means we need to disable or hardcode Nextcloud to v23 for Buster, as v24 won’t support PHP7.3 anymore :frowning:.

No worries, on Buster and Bullseye and all future Debian versions, you can install the meta package as you did without issues.

Can’t wait for next year to drop Stretch support and to get ride of Ondrey PHP repository.

I will see what I can do on putting the pi to a monitor. Don’t have any HDMI monitors atm. Might put it on a tv but then I still lack keyboard. Going to try and see again tomorrow.

Connecting TV would be fine to see if there are error messages

Don’t really know what happend, but when I connected the PI to the TV and the cable to my Plex-server (thus pulling the cable from the Plex), everything worked. When I plug the UTP back in the router (ASUS) or the TP-Link the PI isnt vissible anymore. So either I am going crazy of the PI is. Suspect the last. :slight_smile:

Before you ask, I have the following setup:

modem — Router (ASUS)
| | | |
Plex Bridge* Domoticz TP-Link (4 connections on the ASUS router
iMac Printer PI-Hole Dashticz** MotionEye KODI Wordpress (these are 6 machines on a 16 port TP-link router)

hmm this looks like some issues with cable and or port on the router? Did you tried to change cable and maybe use a different port?

Yes changed cables and ports, not working either. So… Am I crazy now or what :wink:

Is there probably some conflict with hostnames or IP addresses? Is everything managed via same DHCP server and same subnet and in DHCP server as well as on the devices the hostnames all unique?

Yes. I trpple checked that. DHCP is all done through my router, each PI has it’s own hostname.

Where is Plex running on? Do I understand right that unplugging/plugging it alone solves/causes the issue? Probably it creates some network disturbance, like due to a DNS loop, PTR flood or such at the Pi-hole. Probably the Pi-hole query logs reveal something.

Plex is running on a RPi 4. Yes, when plugin the WordPress pi on the cable of the Plex-server it works.

Will check the logs.

Sorry for not replying sooner, but life was a bit chaotic the last few weeks.

Just wanted to say that as of today the webserver is working again. No clue what to what has happend, but I really don’t care, as long as it keeps working.