No login prompt on tty1

Hi. Have problem with no login prompt on TTY1.

My environment:
board: Nano PI M2A
sd card(s): 32G Sandisk and 8G Hama (same problem for both)
screen(s): X710 7’’ 1024x600 (connected to LCD terminal on M2A board) / LG 32 via HDMI (same problem for both)
build/image: latest (DEC 2017) image DietPi_NanoPiM2-armv7-(Jessie).

After proper boot (boot text appeared) regardless the time of waiting I can see on screen info about default login and info from NTPD and have no login prompt.
I followed DietPi-Survey Information and check if commands:
systemctl enable getty@tty[1-2].service
systemctl disable getty@tty[3-6].service

can help. Nope. It doesn’t help. Same problem no login prompt.
On tty2-tty6 login prompt exist and I was able to log into DietPi.
Probably due to this problem with tty1, also autologin (enabled by dietpi-config) changed nothing - can see the same screen with default login info and no prompt nor cli…
After installation (by dietpi-software) LXDE, MATE, Chrome etc and changing autostart accordingly - still the same screen with no login prompt.

Any idea? Can somebody help?

This could also be related to my problem of not getting an SSH terminal. Can you SSH to your pi?

SSH works like a charm. Try to log into dietpi-config and configure SSH service.

I just installed DietPi on my NanoPC-T3 and have the same issue, no login prompt on tty1. SSH works fine to run DietPi-Config and update system. I even installed LXDE and Chromium then rebooted when finished and no luck. Then from SSH I ran startx and the LXDE desktop started on HDMI screen but with PID 700 error. Some functions did not work, so it seems this whole series of NanoPC* has some issues in the image.

I have the same problem as you guys.
I just freshly installed the NanoPi M2 image on my NanoPi 2 Fire (same CPU)
first I had no Login prompt after boot, so after I changed AutoLogin Settings to 2 didn’t work I searched on Google and Downloaded the Virtualbox image to test directly on my big machine.
On my Virtualbox everything worked (including autostart, after I used this patch Mate does not auto start · Issue #1109 · MichaIng/DietPi · GitHub) so back to my NanoPi, applied same Patch no difference.
So I searched again on Google and found this post. Not many Solutions here, but hey I thought OK if more User have this problem so I report a BUG from dietpi-launcher.
Now I had the Idea to search for the used tty’s and found lsdev which does not work :thinking:
After some more research on Google I had the Idea it could be that NanoPi does not use tty1 as first display but tty0, so one ‘ls /dev/tty*’ later, there is a tty0, enabled it via systemctl enable getty@tty0.service and reboot.
now I saw a command prompt, now my mind goes WTF?!?
I typed startx and pushed enter and this fucking machine asks for a password ?!?
After a minute or 2 screen clears and it looks like I am logged in on console
attached is a screenshot

After some more testing I had some freaky outputs look at attached screenshot :open_mouth:

than i had some illogical outputs at ps fax :roll_eyes:

so i did some commands
systemctl enable getty@tty1.service
systemctl disable getty@tty3.service
systemctl disable getty@tty4.service
systemctl disable getty@tty5.service
systemctl disable getty@tty6.service
and a reboot

Now LXDE starts like it should :smiley:

I don’t know why it did not start before, but hey it works