[no HDMI] RPi4BR1.2 4GB & AlloGUI image v7

The pi4 was ordered from pimonori with power adapter and mini HDMI Adapter as advertised for the rpi4.
Mounted the AlloBoss DAC.
Insert the SD with dietpi AlloGUIv7 without changing anything in config.txt.
Boot but no HDMI.
Tried different HDMI 1.4 cables but i cant get a picture.
Both mini HDMI Ports tested.
Waited and accessed the rpi via ssh.
In the Display Options i realised i need to freshen up my knowledge on which Resolution in HD i am going to be using.
Anyway tried with all top three ones.

 vc4-kms-v3d-pi4   : OpenGL | 1920 x 1080    
 vc4-fkms-v3d      : OpenGL | 1920 x 1080
 1080p             : 1920 x 1080

Reboot each time, nothing.

Decided to update,
Update RPi4 EEPROM firmware : [Bootloader: 1599135103 | VL805: 000138a1]

During the Reboot i was able to see some Red background with Text on the Screen for less then a second which at least meant cable is working.

Right now i am guessing the AlloBoss even though not configured is sucking to much power, unfortunately i do not have a usb-c power supply to test this. I can though unscrew everything and test the rpi4 without the AlloBoss DAC.

Removed the AlloBoss DAC but still no HDMI picture so there’s that.

It’s getting late, thinks to check for tomorrow:

  • run a test with noobs image
  • faulty mini HDMI adapter
  • faulty rpi4 board
  • faulty rpi4 power supply

Hi,

usually HDMI video output should work out of the box. At least on my RPi4B I never had an issue with it. You could try as well the normal DietPi RPi image (not Allo).

Started changing / testing switching around hdmi related stuff in config.txt and i do get a Red Striped picture with unreadable text but i can see the boot process is happening.
If i plug the microHDMI adapter into HDMI1 (the further away port from DC) i do briefly see berry and crystal clear Text but just for a fraction of a second, then blank. Need to run more tests on the config.txt settings. I did read though here and there that the HDMI1 port would work when HDMI0 doesn’t.

Also trying to understand why the micro HDMI ports differ from common micro HDMI cables adapter.

crude drawing :

__________
\         /  
 \_______/

usual micro HDMI and

_________
\U ===  U/
 \______/

Raspberry’s Adapter that fits into the pi port.

The Pi cable/adapter has to have two little channels top left / right and something in the top middle where i am guessing its there to hold and support the cable so that it doesn’t slip out. But this middle piece doesn’t allow usual micro HDMI adapters to fit.
It feels like i opted into some apple product series. Please correct me if i am wrong.

On with some more testing and rebooting …

I was hopping the same when i bought everything from pimonoro.
The normal dietpi beta v8 64bit image hangs after brief blinking.
Changing hdmi_safe=1 no boot either.
Tested with both micro ports.

Hit a wall, different SD cards, different img files and all i get is one green blink followed by a longer lasting green LED and when it switches off, nothing. The power LED stays on all the time.

Looks like the pi is dead.

If your Pi’s bootloader is healthy you will see the green light blink a few times and then enter a pattern where it will blink 4 times and then have a long pause. It will repeat these 4 blinks / pause in an endless loop.

Not happening.

source: https://jamesachambers.com/raspberry-pi-4-bootloader-firmware-updating-recovery-guide/

bootloader recovery with different SD cards had no results :cry:

did you tried plian raspberry os 32bit? just for testing https://www.raspberrypi.org/software/operating-systems/#raspberry-pi-os-32-bit

Usually HDMI should work out of the box without any tweaks needed.

Yes, downloaded with raspberry Pi Imager but no dice.
Bought a few new different SD cards.

Run the Eeprom update/restore from the Imager too, green LED blinks and i see fulscreen green but only on HDMI2, HDMI1 stays dark during eeprom recovery.
Without SD card and micro HDMI1 i get striped red fullscreen boot logo where i cannot read the text. On microHDMI2 i see a clear picture and failed to open device ‘sdcard’ spam.
Either case both LED red and green are perma on. afaik green is supposed to be blinking without SD card.

Unfortunately neither OS has managed to boot it up yet, all i see is a microsecond of the Boot logo and a few quick green LED blinks and then darkness on screen and just red LED.

there might be an issue with the device if even plain Raspbian OS is not booting. Maybe you would need to contact the vendor.

I was so focused on getting HDMI output that i forgot how quickly i gave up on this and decided to get Music back up and running quick and then go from there.
Without the HDMI micro adapter connected i am able to boot and install the OS and ssh into the ethernet assigned DHCP address.
Back to where i started.
Lets see if i can get config.txt HDMI settings to give me picture.

Also ordered a second PI with power adapter and micro HDMI adapter from another distributor.

hdmi_safe=1

Result:


HDMI0: Red Striped back round with big read able font, obviously something buggy
HDMI1: quick flash then black screen, though i think its a brighter black

Not sure if i will find a setting that works, i do believe something is faulty and can only test when order arrives.

Joulinar
About the micro HDMI port difference i am experiencing, out of curiosity, can you plug in any micro HDMI cable into the rpi4? Did you use any force to push them in?

maybe the issue is with the HDMI micro adapter ??

I was getting a crystal clear picture on HDMI1 the port further away from power, which would indicate adapter works.

Right now i am trying to get this second port HDMI1 running, that just shows a bright black. So far only see a boot picture and only when no SD card is inserted.