No Audio on ShairPort and Spotify on Sparky USBridge

I have installed raspotify on my new Sparkybridge connected via USB to a TEAC UD501

On the very first try Raspotify ans Shairport both worked flawlessly.

Today it is different !!
I can select DietPi (Raspotify) on my phone but there is no sound coming out
and if I select the airplay output, the audio start, then spotify switch immediatly on the phone output and the shaiport
is automaticy switched on :status = Inactive - Shairport sync = Disable

I also have the GMRender active, and I have no problem to play any song via DLNA.

thanks for your help

Problem solved With SharePort by setting the audio output on 24 Bits - 44100 Hz

Problem still pending with Raspotify …I suspect that I need to force the Audio output of the Usbridge to 24 bits when using spotify …
but I do not know how to achieve that …

There is also no information (blank line) in the Allo Web Interface, regarding th Status of the ALSA OUTPUT STREAM INFORMATION …


Unsure also with regards to Raspotify, the config file is available below, but I cannot see any options relating to output bitdepth:


The ALSA output information, only displays when audio playback is active on the device. Simply refresh the page when audio is playing (eg: F5).

Hi Fourdee

I agree that there is no option related to bitdeph in the raspotify config. I also tried to set the best audio BITRATE="320
in the config file but without any success.

I also did refresh the allo web page after playing a song with spotify and having selected dietpi as output.

During my very first try of Spotify I got it playing correctly … thats why I tend to beleive that it is related to a bad parameter
set … but it is only my guess