No audio from hifiberry dac+ pro XLR on RPi 3b+ WAS WORKING


I’m sorry that I don’t have a better trail of “what happened” but here’s what I do know.

  1. I have three RPi 3B+'s all running DietPI in auto update mode (my suspicion as to what happened)
  2. Two have the hifiberry dac+ pro XLR, and one just has the hifiberry dac
  3. All have Roon Bridge, Raspotify, and Shairport installed via diet-pi, with defaults (a bit of tweeks on levels on alsa on one of them to keep from blowing out a set of monitors).
  4. Until last week sometime, or maybe the week before - all were rendering audio from Spotify, Roon, and iTunes
  5. Sometime the end of last week, I tried to stream a spotify to one of the XLR dacs, no audio. tried roon, no audio, tried the other xlr dac, same. However the plain hifiberry dac is still working.
  6. Connected another dac (not using the RPi) to the monitor speakers that had been on the RPi - music.
  7. Thinking an upgrade got borked, re-installed DietPi (clean) on one of the XLR dac’s. No joy

So - where should I look next? I didn’t change anything between working and non-working, so the only thing I can come up with is an upgrade borked something.