NFS does not work; no shares found in network

after I exchanged an - too hot - Odroid XU4 against a fabolous Odroid N2, the network access of an Android TV (Nvidia Shield TV) doesn’t work anymore.

Never had any issues but and streames videos via NFS without any problems using KODI as a client.
Now KODI does not recognize any NFS share in the network.
I have reset the Nvidia Shield TV completely, but the problem still exists.

Alternatively I tried Samba. Again, the client does not recognize any shares in the network, but at least I was able to access the network after entering the path with user and password. Unfortunately the picture freezes here after a few seconds.

I also have a new Router - a Fritzbox 6591 - but it is configured like the old Fritzbox 7530 i had before.
But i think i should mention this.

NFS and Aamba are installed.
First I added the dietpi_userdata in exports but it is also in /exports.d so i deleted my edit and now both services start with an OK.

Can you help me further?

BTW: How do i get some logs from ramlog?


did you tried to manually enter the NFS within your Kodi client?

If you application is writing logs to the standard directoty, logs are available on /var/log. However they are cleaned every hour as well as they are not boot persistent. Ramlog means, they are not written down to SD card but they are available on same directories as usual. To get fresh logs, just restart the respective service of your application or adjust the log mode within dietpi-software.