Nextcloud suddenly requires PHP 8.0.2 or lower, so I can't access

Required Information

- DietPi version

- Distro version

- Kernel version
Linux DietPi 5.10.0-21-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux

- SBC model
Native PC (x86_64)

- Power supply used
Some 700W Corsair PSU

- SD card used
No SD card, installed OS on a modern SSD, nextcloud data is mostly on mounted HDDs

Additional Information (if applicable)

- Software title

- Was the software title installed freshly or updated/migrated?
It may have happened right after installing a new nextcloud update, or at least not long after

Steps to reproduce

  1. Open nextcloud webUI

Expected behaviour

  • I should be able to use nextcloud like normal

Actual behaviour

  • Error screen saying there is a internal server error

Extra details

  • I have heard that certain apps may cause this problem, due to requiring a higher PHP version than installed. I did install a new archive manager app, but it worked fine before I started getting this error.

Did you update to NC26?

@MichaIng do you know if the update to NC26 is offered on Debian Bullseye PHP7.4? I guess NC guys would need to block the update on PHP7.4 systems.

1 Like

I thought the update is blocked? At least I remember seeing the code for the block in even two places: Once for downloading and installing new files, and once when applying the database/config migration.

And on our internal Nextcloud instance the update is not offered. But probably it was not the update to Nextcloud 26 but 25.0.5 instead @Some_ordinary_dude?

Also which webserver do you use?

And please post the output of the following commands:

journalctl -u php7.4-fpm
tail -10 /mnt/dietpi_userdata/nextcloud/nextcloud.log

Please check the output for private or identifying content and remove/mask it before posting it here.

1 Like

Yes, it was updated to 25.0.5

I use the Nginx web server

The command you requested:

tail -10 /mnt/dietpi_userdata/nextcloud/nextcloud.log
-- Journal begins at Sat 2023-03-25 05:12:46 GMT, ends at Sun 2023-03-26 13:30:54 BST. --
Mar 25 05:12:58 DietPi systemd[1]: Starting The PHP 7.4 FastCGI Process Manager...
Mar 25 05:12:58 DietPi systemd[1]: Started The PHP 7.4 FastCGI Process Manager.
tail: cannot open '/mnt/dietpi_userdata/nextcloud/nextcloud.log' for reading: No such file or directory

Strange, it found no log file

Sorry, wrong path, it’s

tail -10 /mnt/dietpi_userdata/nextcloud_data/nextcloud.log
1 Like

Now that’s a nice wall of text… I’m using a zerobin service for that

“message”:“Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.0.2". You are running 7.4.33. at /var/www/nextcloud/apps/files_archive/vendor/composer/platform_check.php#24”,“userAgent”:“–”,“version”:“”,“exception”:{“Exception”:“Error”,“Message”:“Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.0.2". You are running 7.4.33. at /var/www/nextcloud/apps/files_archive/vendor/composer/platform_check.php#24”,“Code”:0,“Trace”:

hmm NC requires PHP8 already? I thougt the switch will be on NC26?


Just tested NC on Debian Bullseye without issues :thinking:

root@DietPiR6S:~# ncc status
  - installed: true
  - version:
  - versionstring: 25.0.5
  - edition:
  - maintenance: false
  - needsDbUpgrade: false
  - productname: Nextcloud
  - extendedSupport: false
root@DietPiR6S:~# php -v
PHP 7.4.33 (cli) (built: Feb 22 2023 20:07:47) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.33, Copyright (c), by Zend Technologies
1 Like

I have also no problems on aarch64, but OP runs x86_64. Which plattform did you test?

Also 8.0.2 is not a correct version string. Ah, wait a minute, this check is not done by Nextcloud, but by the files_archive app it seems. So this app is the culprit, requiring a newer PHP version than Nextcloud itself: nextcloud-app-files-archive/ at 1ad0ed9983e7db407cbfe186035257d98cbd9243 · rotdrop/nextcloud-app-files-archive · GitHub

Not sure how this ever worked before since this app did require this PHP version from its very first version/commit on.

Ah, so installing this app indeed was the reason.

Does CLI work?

ncc app:disable files_archive
ncc app:remove  files_archive

Thanks, it works now!

It’s strange, since I successfully extracted ZIP files on the GUI web interface. Then, presumably after a refresh, it stopped working.

Probably some frontend buffer prevented the crash at first.

1 Like