Nextcloud Samba external storage not connecting

Is SMB / CIFS external storage working in bundled Nextcloud v17.0.1 (DietPi v6.28.0)? Thanks.

I get this error when testing with “SMB connection test”.

Using backend: smbclient

Error while loading share content.

Icewind\SMB\Exception\ConnectionException: Connection not valid

    /var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Wrapped/Share.php - line 412:


    /var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Wrapped/Share.php - line 146:

    Icewind\SMB\Wrapped\Share->execute("cd \"\"")

    /var/www/nextcloud/apps/smb_test/lib/Controller/SmbController.php - line 95:


    /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 170:

    OCA\SMBTest\Controller\SmbController->dir(null, null, null, null, Icewind\SMB\ ... }}, null)

    /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 99:

    OC\AppFramework\Http\Dispatcher->executeController(OCA\SMBTest\ ... {}, "dir")

    /var/www/nextcloud/lib/private/AppFramework/App.php - line 126:

    OC\AppFramework\Http\Dispatcher->dispatch(OCA\SMBTest\ ... {}, "dir")

    /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47:

    OC\AppFramework\App::main("OCA\\SMBTes ... r", "dir", OC\AppFramew ... {}, { _route: "smb_test.smb.dir"})

    OC\AppFramework\Routing\RouteActionHandler->__invoke({ _route: "smb_test.smb.dir"})

    /var/www/nextcloud/lib/private/Route/Router.php - line 297:

    call_user_func(OC\AppFramew ... {}, { _route: "smb_test.smb.dir"})

    /var/www/nextcloud/lib/base.php - line 1000:


    /var/www/nextcloud/index.php - line 42:


Many thanks for your report. There is no bundled versions. DietPi is using the official version that is offered by NextCloud. You could try to update to latest Nextcloud version 17.0.2. This should be possible within Nextcloud application. If this is not fixing your problem, you might need to report it at Nextcloud directly.

Have you tried using this.


as well there was a new Nextcloud version 18 released. Maybe you can updated to the new release.

Not 100% sure, but probably the mount point of the SMB share needs to be owned by www-data, respectively it needs write access to this mount point to allow it mounting a share there?

I tested today on NectCloud 17.0.2 and I was able to connect to my Synology NAS using the external storage App.

on NextCloud 17.0.1 this was not possible. As well keep in mind to install smbclient first, otherwise SMB / CIFS connect are not working.

So my RPi was running whole night with a mounted share from my Synology. I have seen that my Synology disk was going to hibernate without issues. The share was still mounted on the RPi. It did not get lost. Access was still possible this morning. I did not find any issues in journalctl regarding the mount.

Bottome line. A mounted Synology Share is not preventing the Hibernate Mode as well as it stays connected/accessible on DietPi.

Thank you Joulinar, it worked after updating to 17.0.2.

What is the recommended way to update Nextcloud on DietPi?


the way is the same on normal Debian as well as on DietPi. Not that much differences. I would use the NextCloud build-in updater as officially described on NextCloud website

All right, just wanted to be sure, thank you. Have a nice evening!