Nextcloud port forwarding

Hi my ISP SHAW CABLE blocking port 80/443 so i need to change other port to get it works again , Does anyone know how to do this ?

I don’t have much skill for this can someone step by step teach me ? Thanks !

Question is if your broadband router is allowing your to forward other ports. If yes you could try to forward whatever port from internet to port 80/443 intern.

I don’t know if i am correct or not because i am new for this , I have a unraid server setup and i port 444/51413 for transmission is working , And i read some shaw cable ( bluecruve as modem ) they start blocking 80/443 this year .

as said above, have a look to your router and check if your are able to forward

extern 8080 > intern 80
extern 8443 > intern 443

i don’t think i have that option in “bluecruve” modem

but you already forwarding ports right?

I only have this option Before it was working for my odroid xu4 80/443 , For example after i install dietpi - nextcloud , local ip it works i can load the nextcloud setup page , and then port forwarding 80/443 , then i enter my IP ( not local ip ) 24.xx.xx.xx/nextcloud it suppose to load the nextcloud page like local ip before i setup dns but now it’s not working anymore .

Since i read some shaw customer i found out shaw start blocking 80/443 , here is the like below :

if you go for the edit button`on the xu4 entry, how does it looks like?

That is the edit page with add port forward button

can you share a picture of the options available?

There is not too much option/setting in stupid shaw bluecruve modem , and also they starting to block 80/443 this year

Question is since shaw modem can use bridge mode , Does it work if i get a asus router for port forwarding without any problem ?

that’s really some kind of a stupid router. Sorry to say but I can’t answer the question if an Asus router in bridge mode will solve this.

Anyway, let’s try to change the HTTP port first to see if this is working.

G_CONFIG_INJECT 'server.port                 =' 'server.port                 = 8080' /etc/lighttpd/lighttpd.conf
systemctl restart lighttpd

This should change http to port 8080

i don’t think it’s working that way , i think i am going to get a ax6600 router and use my own port forwarding :frowning:

What exactly is not working?

Spent many hours and tried change port 80/443 to 8080/8443 still not working Stupid Shaw cable also updated NAT setting on their bluecruve modem without any notice untill i saw this post , And some of shaw customer report the port forwarding has been removed , i also contacted their tech support team yesterday they ask me to get a router for port forwarding which i believe they removed the port forwarding feature .

WTF, hope you are able to get a different modem/router that supports portforwarding.

Yes i just purchased a Asus RT-AX92U AX6100 Tri-Band Wi-Fi 6 Mesh Router it’s 20% off on amazon and i am living 640sqft apartment the connection shouldn’t be a problem , save few bucks to get AX6600 :slight_smile:

And today i received my N2+ from hardkernel . it’s a upgrade for my old xu4 hopefully everything works , Thanks for helping me !

good luck with the new router. Hope it’s going to solve your issue.