Nextcloud folder not visible in Dietpi and Aria2

Hi folks,
i set up Dietpi with Nextcloud, Pihole, PiVPN and Aria2. Now i want to use Aria to download into a manually created nextcloud-folder (i.e. nextcloud/documents/mine).
The folder “mine” was created in Nextcloud and is visible in the nextcloud app on android, apple and windows.
But its not visible in the commandline in Dietpi (user:root) and hence not visible to aria for download. I would be thankful for every hint.

The folder should be located in /mnt/dietpi_userdata/nextcloud_data/<username>/files/documents/mine where <username> is the user of nextcloud (default: admin, if you didn’t change or added another)

Ty for your feedback.
I know the path to the folder and can access it -
but the sub- folder “mine” is not visible in the command-prompt on dietpi.
It might be a user - permission problem? - user root <----> admin
Yes, the user is admin

Hmm this is odd. Root should see everything and in my case, I can cd into my created folders and I also can access them via samba.
Is this a folder inside the default documents folder, which was created automatically after the installation?

“documents” was there.
I created the subfolder “mine” via Windows.

Nextcloudpi is accessible on Windows via Explorer (since i installed the nextcloud-app)
Trying to create a subfolder on dietpi…
maybe that helps.

Edit: That didn´t help

Are we talking about same folder? Because you are running NextcloudPi. This is a different app than our Nextcloud install and hence uses different directories.

Im not sure if I understand your problem, but when you create files and folders outside from the webUI or the nextcloud Apps (e.g. with mkdir via CLI), you need to reindex your files so they get added to the database.
sudo ncc files:scan --all

I found out, that even the standard “Documents” folder can´t be used in aria2.
“Documents” is visible and accessible in Dietpi.
I guess its a permission problem

sudo ncc files:scan --all

gives me:

sudo: ncc: Befehl nicht gefunden

means “command not found” in german

but it worked without “sudo”

that worked -
subfolder “mine” (created on windows) still not visible

“maga” (created with mkdir in dietpi) is now visible in the Android app, but not on windows - that seems to work a bit

the main problem, in my opinion, is that aria2 (from the webui via http) cant access the Nextcloud - folders on dietpi

yes its nextcloud from the dietpi - menu.

I think you need to add the user, which runs aria2, to the www-data group, since www-data has read/write/execute permissions for this folders.

sudo usermod -a -G www-data <username>

The fact that you don’t see some folders sounds like a sync issue.

since i dont know the user of the webui-login (no user is set - just the root password),
i added the user “root” as username in the connection-settings of aria2 in the webinterface.

Downloads are possible, but into the /mnt/dietpi_userdata/downloads directory.
not into:


I ll try a workaround.

TY for your help that late on time.

You can see the user which runs a process in htop.
The username for aria2 is aria2 :sweat_smile:

And don’t forget: If you add files to your nextcloud folders this way you have to rescan them every time to integrate the new files into the nextcloud database, otherwise they are not visible in the nextcloud Apps/ webUI etc.

I did a bit of testing, I added aria2 to www-data, and changed the download location to my nextcloud folder, but I also get the error could not create new file or truncate existing file.

1 Like

ty mate.
Since the userdate created in nextcloud for Windows was not visible to either Dietpi/ Android/ Apple i uninstalled the app.
Now i am trying to establish an smb connection from windows to the Dietpi - filesystem.

I did this earlier, when i was just running nextcloudpi - without dietpie.
The trouble with aria2 <----> nextcloud surely is unsolved

TY that for the hint!

Another hint for SMB: Install avahi-daemon, otherwise your share is not visible in your network overview in windows and you have to type in manually the IP / hostname :slightly_smiling_face:

1 Like

First get clear on file system NextcloudPi is using. As NCPi is a different app than the original NC, it might use different file system. Next, it is not recommended to add files outside NC to NC file system. At least this I found on NC forum.

At the end it will be file system permission you need to manage. Don’t mix the user inside app with the user used on OS level.

For this you simply could install WSDD