Nextcloud error in Admin Panel - 64 bit

Required Information

  • DietPi version

  • Distro version
    bookworm 1

  • Kernel version
    Linux DietPi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux

  • Architecture

  • SBC model
    RPi 4 Model B (aarch64)

so the Nextcloud admin panel shows me the following warning:

It seems like you are running a 32-bit PHP version. Nextcloud needs 64-bit to run well. Please upgrade your OS and PHP to 64-bit! For further details read the documentation page :arrow_upper_right: about this.

I’m not sure if I misunderstood something, but I figured I’m running a 64-bit OS (aarch64) on 64-bit hardware. I recently updated my DietPi to Bookworm (and to Bullseye a couple of years before that).

If I check with getconf LONG_BIT I get 32. I’m guessing this is the reason for the message in the Admin panel, but now I’m wondering:
Is this something that can be fixed by changing some configuration or is a completely new install necessary to get a 64-bit install that Nextcloud is fine with?

You have a 32bit system

Kernel has enabled 64bit mode.

However your system is still running 32bit userland. A couple of months back, Raspberry developer enable 64bit kernel mode for all RPi4 device by default. But this doesn’t mean you are running a 64bit system fully :wink:. Theoretically you could set back kernel to 32bit but it will not have any positive impact on NC.

This is now what NC is complaining about. To get a real 64bit system, a complete new installation of our 64bit image would be needed. There is no way to migrate from 32bit to 64bit.

I feared as much. When selecting the image for a new install there is no selection for 32 or 64 bit, so I assume it will be 64 automatically?

It should be the ARMv8 image.

Ok, thank you for the info and help!