Nextcloud don't work after 4 months

Good Day,

It worked very well and all of a sudden I can’t access the page. All other pages like local “Wikipedia”, “Portainer” and also “Webmin” still work.
When I call “netstat” I don’t see any port.
In addition, I have already started “dietpi-software reinstall 114” and also no success.
Maybe someone has an idea where I can look it up why it does not work.

can everyone tell me at which point nextcloud will start?

Thank you for any answer.
Greetings
Jan

Does it give any error message while opening web page http://your.ip.com/nextcloud ?

What is the status of all your service

dietpi-services status

Hello,
i see:

root@DietPi:/etc/init.d# dietpi-services status

 DietPi-Services
─────────────────────────────────────────────────────
 Mode: status 

[  OK  ] DietPi-Services | nmbd			 active (running) since Sat 2022-03-12 10:12:22 CET; 7h ago
[  OK  ] DietPi-Services | smbd			 active (running) since Sat 2022-03-12 10:12:23 CET; 7h ago
[  OK  ] DietPi-Services | redis-server		 active (running) since Sat 2022-03-12 10:12:23 CET; 7h ago
[  OK  ] DietPi-Services | mariadb		 active (running) since Sat 2022-03-12 10:12:26 CET; 7h ago
[  OK  ] DietPi-Services | php7.4-fpm		 active (running) since Sat 2022-03-12 10:12:27 CET; 7h ago
[  OK  ] DietPi-Services | nginx		 active (running) since Sat 2022-03-12 10:12:27 CET; 7h ago
[  OK  ] DietPi-Services | lighttpd		 activating (start-pre) since Sat 2022-03-12 17:35:50 CET; 643ms ago
[  OK  ] DietPi-Services | webmin		 active (running) since Sat 2022-03-12 10:12:36 CET; 7h ago
[  OK  ] DietPi-Services | docker		 active (running) since Sat 2022-03-12 10:12:37 CET; 7h ago
[  OK  ] DietPi-Services | cron			 active (running) since Sat 2022-03-12 10:12:37 CET; 7h ago
[  OK  ] DietPi-Services | dropbear		 active (running) since Sat 2022-03-12 09:57:32 CET; 7h ago
[ INFO ] DietPi-Services | dietpi-vpn		 inactive (dead)
[ INFO ] DietPi-Services | dietpi-cloudshell	 inactive (dead)
[  OK  ] DietPi-Services | dietpi-ramlog	 active (exited) since Sat 2022-03-12 09:57:32 CET; 7h ago
[  OK  ] DietPi-Services | dietpi-preboot	 active (exited) since Sat 2022-03-12 09:57:36 CET; 7h ago
[  OK  ] DietPi-Services | dietpi-postboot	 active (exited) since Sat 2022-03-12 09:57:56 CET; 7h ago
[ INFO ] DietPi-Services | dietpi-wifi-monitor	 inactive (dead)

there is no Nextcloud!

and the next information

root@DietPi:/etc/init.d# systemctl status php7.4-fpm.service 
● php7.4-fpm.service - The PHP 7.4 FastCGI Process Manager
     Loaded: loaded (/lib/systemd/system/php7.4-fpm.service; disabled; vendo>
     Active: active (running) since Sat 2022-03-12 10:12:27 CET; 7h ago
       Docs: man:php-fpm7.4(8)
    Process: 4172 ExecStartPost=/usr/lib/php/php-fpm-socket-helper install />
   Main PID: 4155 (php-fpm7.4)
     Status: "Processes active: 0, idle: 4, Requests: 0, slow: 0, Traffic: 0>
      Tasks: 5 (limit: 2178)
        CPU: 3.398s
     CGroup: /system.slice/php7.4-fpm.service
             ├─4155 php-fpm: master process (/etc/php/7.4/fpm/php-fpm.conf)
             ├─4168 php-fpm: pool www
             ├─4169 php-fpm: pool www
             ├─4170 php-fpm: pool www
             └─4171 php-fpm: pool www

Warning: journal has been rotated since unit was started, output may be inco>

there is no Nextcloud!

Nextcloud is not an own application. It a web server app running on a web server like Nginx or Lighttpd.

And I see both installed on your system, with it not a good idea as they are conflicting with each other. Do you recall why both are installed? Did you have done any installation? Usually our scripts should prevent from doing this.

i pushed the command

dietpi-software list

ID 114 | =2 | Nextcloud: File sync, sharing and collaboration platform | +MariaDB +PHP +Redis +webserver | https://dietpi.com/docs/software/cloud/#nextcloud

i dont know what is the best way?

i dont know what is the best way?

For what?

As said, Nextcloud is not a dedicated app. It’s a web server application.

Still my question, do you recall why you have 2 conflicting web server installed

At first, thank you for the fast answers!!!

How can i check this?
All webservices are working normaly.
Only the Nextcloud are not there.
Dietpi-Software say to me it is installed.
My idea is to uninstall dietpi, reboot an after this i will install new the nextcloud.
Or you have a better idea?
In the folder /var/www/nextcloud are all files.
And in the file “/etc/lighttpd/conf-enabled/99-dietpi-nextcloud.conf” i think this is the right one is there.

How can i try to start the software from the command?

Which webserver do the working webservices use? Nginx?

You didn’t get the problem: You have installed Nginx and Lighttpd (which are both webservers) but they couldn’t coexist easily side by side.

So the problem might be that your working webservices using Nginx but Nextcloud want’s to use Lighttpd. But it’s not possible, because it’s conflicting with Nginx.

what gives you systemctl status lighttpd ?

Still you misunderstood. Don’t mix services like Portainer or webmin. They have their own web server and no relation to Nextcloud. They are completely independent.

At the moment you have 2 conflicting http web server installed. icode]Nginx[/icode] and lighttpd. Both do very same thing, providing Http service on port 80/443. Usually they are not able to run together. That’s most probably the cause of your issue.

Still the question why you have both installed. Usually our scripts prevent this. Did you have done something to install Nginx in addition to lighttpd?

thanks you too,

you see my answers

root@DietPi:/var/www/nextcloud# cd /etc/
root@DietPi:/etc# systemctl status lighttpd
● lighttpd.service - Lighttpd Daemon
     Loaded: loaded (/lib/systemd/system/lighttpd.service; disabled; vendor >
     Active: active (running) since Sat 2022-03-12 21:11:04 CET; 991ms ago
    Process: 12907 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/ligh>
   Main PID: 12912 (lighttpd)
      Tasks: 3 (limit: 2178)
        CPU: 2.843s
     CGroup: /system.slice/lighttpd.service
             ├─12912 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
             ├─12915 /bin/sh -c /usr/share/lighttpd/create-mime.conf.pl
             └─12916 /usr/bin/perl -w /usr/share/lighttpd/create-mime.conf.pl

Mär 12 21:11:02 DietPi systemd[1]: Starting Lighttpd Daemon...
Mär 12 21:11:04 DietPi systemd[1]: Started Lighttpd Daemon.
root@DietPi:/etc# systemctl status lighttpd
● lighttpd.service - Lighttpd Daemon
     Loaded: loaded (/lib/systemd/system/lighttpd.service; disabled; vendor >
     Active: active (running) since Sat 2022-03-12 21:11:04 CET; 991ms ago
    Process: 12907 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/ligh>
   Main PID: 12912 (lighttpd)
      Tasks: 3 (limit: 2178)
        CPU: 2.843s
     CGroup: /system.slice/lighttpd.service
             ├─12912 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
             ├─12915 /bin/sh -c /usr/share/lighttpd/create-mime.conf.pl
             └─12916 /usr/bin/perl -w /usr/share/lighttpd/create-mime.conf.pl

Mär 12 21:11:02 DietPi systemd[1]: Starting Lighttpd Daemon...
Mär 12 21:11:04 DietPi systemd[1]: Started Lighttpd Daemon.

I guess we still misunderstood each other. We ask for the reason to have 2 identical web server installed. Nixing as well as lighttpd. But ok.

Can you share following

ss -tulpn | grep LISTEN
dietpi-software list | grep " =2 "

Good Morning from Hamburg,

i have to uninstall some software and the lighttpd is the standard webserver.
The nextcloud is reinstalled but it don’t will work!
My last options is to restall my raspberry pi again.
Or have one another a idea?

At this place you see my config

root@DietPi:/var/www# ss -tulpn | grep LISTEN
tcp   LISTEN 0      128            0.0.0.0:8090      0.0.0.0:*    users:(("kiwix-serve",pid=302,fd=3))                                                                                                
tcp   LISTEN 0      50             0.0.0.0:445       0.0.0.0:*    users:(("smbd",pid=12502,fd=44))                                                                                                    
tcp   LISTEN 0      80           127.0.0.1:3306      0.0.0.0:*    users:(("mariadbd",pid=12591,fd=16))                                                                                                
tcp   LISTEN 0      511          127.0.0.1:6379      0.0.0.0:*    users:(("redis-server",pid=12519,fd=7))                                                                                             
tcp   LISTEN 0      50             0.0.0.0:139       0.0.0.0:*    users:(("smbd",pid=12502,fd=45))                                                                                                    
tcp   LISTEN 0      511            0.0.0.0:80        0.0.0.0:*    users:(("nginx",pid=12666,fd=6),("nginx",pid=12665,fd=6),("nginx",pid=12664,fd=6),("nginx",pid=12663,fd=6),("nginx",pid=12662,fd=6))
tcp   LISTEN 0      1000           0.0.0.0:22        0.0.0.0:*    users:(("dropbear",pid=339,fd=4))                                                                                                   
tcp   LISTEN 0      50                [::]:445          [::]:*    users:(("smbd",pid=12502,fd=42))                                                                                                    
tcp   LISTEN 0      50                [::]:139          [::]:*    users:(("smbd",pid=12502,fd=43))                                                                                                    
tcp   LISTEN 0      511               [::]:80           [::]:*    users:(("nginx",pid=12666,fd=7),("nginx",pid=12665,fd=7),("nginx",pid=12664,fd=7),("nginx",pid=12663,fd=7),("nginx",pid=12662,fd=7))
tcp   LISTEN 0      1000              [::]:22           [::]:*    users:(("dropbear",pid=339,fd=5))



ID 1 | =2 | Samba Client: access SMB/CIFS/Samba network shares | |  dietpi-drive_manager > Add network drive
ID 3 | =2 | MC: midnight commander, powerful file manager |
ID 20 | =2 | Vim: vi enhanced text editor |
ID 82 | =2 | LLMP: Lighttpd | MariaDB | PHP | +Lighttpd +MariaDB +PHP | https://dietpi.com/docs/software/webserver_stack/#llmp-web-stack
ID 84 | =2 | Lighttpd: Extremely lightweight webserver | +PHP | https://dietpi.com/docs/software/webserver_stack/#lighttpd
ID 88 | =2 | MariaDB: Persistent cached file-per-table database server | | https://dietpi.com/docs/software/databases/#mariadb
ID 89 | =2 | PHP: Hypertext Preprocessor for dynamic web content | | https://dietpi.com/docs/software/webserver_stack/#php
ID 91 | =2 | Redis: Volatile in-memory non-SQL database server | | https://dietpi.com/docs/software/databases/#redis
ID 96 | =2 | Samba Server: Feature-rich SMB/CIFS server | | https://dietpi.com/docs/software/file_servers/#samba
ID 103 | =2 | DietPi-RAMlog: Makes /var/log a RAM disk, preserves file structure on reboot | | https://dietpi.com/docs/software/log_system/#dietpi-ramlog
ID 104 | =2 | Dropbear: Lightweight SSH server | | https://dietpi.com/docs/software/ssh/#dropbear
ID 114 | =2 | Nextcloud: File sync, sharing and collaboration platform | +MariaDB +PHP +Redis +webserver | https://dietpi.com/docs/software/cloud/#nextcloud

Good morning from Berlin

There is no need to reinstall everything. The issue is pretty clear. You have a conflicting web server Nginx installed. Nginx prevents lighttpd form being able to start correctly. it’s as well not part of installed software list. Therefore, still our question: why do you have Nginx installed? How did you do that? What was the reason?

Basically you could try to stop/disable Nginx and restart lighttpd

systemctl stop nginx
systemctl disable nginx
systemctl restart lighttpd

You are so good!!!

Thank you Thank You so much.

I worked very well !!!

Thank you !!!

Well we just worked around the fact that you have 2 times a web server installed, conflicting with each other.

And still the million dollar question your did not answer until now: Why do you have Nginx installed? How did you do that? What was the reason?

I think that was at the point in the Dietpi-Software there is a point “Default Webserver”.
If i click on this point it will be change to NGINX i can’t change back.

Now I have the Problem again…

my solution was

systemctl stop nginx
systemctl disable nginx
systemctl restart lighttpd

Dietpi-software reinstall 114

systemctl stop nginx
systemctl disable nginx
systemctl restart lighttpd

And all my configs are back… Yes !!!
Thank you for your help :smiley:

I highly recommend to remove nginx if not needed. Otherwise you will run into issues again and again and again.