Nextcloud change placeholder page?

Ok, so I am really new at this sort of thing, just started today actually:

did some googling
-got the pi
-got a 1tb raid 1 nas
-got a full unifi setup


Setup the Unifi switch, usg and ap and cleaned/hid the wires

Setup the Pi(not very hard, I bought a PoEhat as well, so you just plug in to the Ethernet.)

more googling and youtube now!
-found dietpi
-found nextcloud
-started the installs
-moved the userdata over(after some issues which took about 10 reformats to stock, before just finding an order that worked)

more googling here

Bought a domain name
-hopped onto the nameserver
-added an A name for the domain I bought

Much googling and youtube!

Hopped onto Unifi
-port forwarded 80 and 443
-set wan local to the IP address with the portgroup i created

Lots more googling
(the amount of tutorials I went through just to get this far is staggering.)

And Brick Wall.

At this point I decided, well, I’ve gone as far as I can starting with absolutely zero knowledge…Let’s sign up and ask some people who probably know a lot more than me.

So I believe there are two issues

1.) When i tried to connect to the remote IP…it doesn’t work…Not even the landing page, so I must have either:
a.) Screwed something up with my port configurations
b.) Not screwed something in correctly in the pi(very possible…Nano…Vim…Vi, lets learn them all today! And learn that Vi and Vim arent the same thing!)

2.) When I connect to it locally, I have to type localipaddress/nextcloud, if i just type localipaddress, i get a lightppd placeholder page, I read somewhere about issues with lightppd and something about apache (This should just be mandarin, that’s about all I saw.)

If anyone could offer me their assistance, it would be lovely!

Note that it is expected that websites are reachable via URL path instead of IP/domain only. This is the only way how multiple webserver applications can be reachable.

You can manually add some rewrite rule or change the webroot, but note that this will break other dietpi-software installs and/or will be reverted by them. However we have an open feature required to enable this:

I have no experience with unifi, so can’t help with this currently. I am used with router/NAT + port forwarding, so if the Pi is reachable via local IP, then everything else is part of the router/network setup.