Nextcloud and Owncloud Installation

Everything works fine until I get to the download of either of these. Then it says it cannot connect to the download site. Internet connection is fine as it downloaded everything before this step. Ideas?

Many thanks for your report.

Pls can you be a little bit more specific on your issue.
Do you have some error messages or screenshots you can past?

pls can you run the following 2 commands an past the output

ping -c 1
ping -4 -c 1

root@DietPi:~# ping -c 1
PING (2a01:4f8:130:32f1::52)) 56 data bytes
64 bytes from (2a01:4f8:130:32f1::52): icmp_seq=1 ttl=44 time=127 ms ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 127.376/127.376/127.376/0.000 ms

root@DietPi:~# ping -4 -c 1
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=49 time=122 ms ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 122.481/122.481/122.481/0.000 ms

weird. yesterday you reported an issue that you are not able to resolve the host name.

unable to resolve host address ‘’

but today you are able to resolve the name for both IPv4 as well as IPv6 as shown in your test.

PING IPv6 (2a01:4f8:130:32f1::52)

So connection should work.

pls can you try to restart your software installation!

I restarted and get the same error. It’s very odd.

well you could try to tweak it by entering the IPv4 as well as IPv6 address to your /etc/hosts file. This should avoid the DNS resolving error at least.

BTW what DNS/Nameserver you are using. Your own one or a public like Google or Cloudflare

I am using my own - pihole, however I have it disabled while doing this. Should I try another?

well maybe for testing you could switch to Google or Cloudflare. But usually PiHole should show blocked request. As well you could go to whitelist within PiHole. Or tweaking /etc/hosts as another option :sunglasses:

I’m a bit of a noob.

How do I edit that etc/hosts?

You can do the following

nano /etc/hosts

add the following two lines

Save the file. To be on save side, reboot your system. Now your system should resolve by using the /etc/hosts instead of asking PiHole

Well I made progress looked like the hosts file worked and then ran into this -
│ oud.conf
│ Resolving (… failed: Connection

Maybe I am not meant to do this LOL

did you tried to change your DNS Server to ??

If yes and you still facing this issues, we would need to continue adding IP’s to the /etc/hosts file :rofl:

well didn’t help LOL

what IP addresses next? :cry:

your system getting more and more weird :thinking:
Anyway let’s do the following to enable you to find out IP addresses yourselves :wink:
Pls install the small package dnsutils. It will install the tool nslookup which can be uses to check DNS and what will be resolved.

G_AGI dnsutils

once done you can run the command


your preferred DNS server should now answer the following

root@DietPi4:~# nslookup
Server:                 <--- my own DNS serer

Non-authoritative answer:       canonical name =
Address:                       <--- DNS serer feedback


take one of the IP addresses and put it into your /etc/hosts. If you have IPv6 working, you will receive IPv6 addresses as well.

I’m thinking this isn’t meant to be for some reason :frowning:

yes there is something strange on your system. You have DNS issues during installation but testing ping is working fine. I still don’t understand why this happen. Maybe you could disable IPv6 within dietpi-config Network settings and test again.