Nextcloud 27 max upload size

I have a Dietpi OS running on rp3 with nextcloud 27 along with lighttpd webserver.
I am to increase the file upload size to 10GB. However i ve got a bit lost in exactly how to do it, which file/files to modify. I “played” around with different settings in

; priority=99
upload_max_filesize 10G
post_max_size 10G
max_input_time 3600
max_execution_time 3600

but nothings works well.
Where and what shall i do to achieve the upload size increase to 10GB?
thank you

When you are not on 32bit you already should be able to upload 8796 PiB.

The nextcloud app shows 512MB limit.

You can change that by adding the lines

php_value upload_max_filesize 10G
php_value post_max_size 10G
php_value max_input_time 3600
php_value max_execution_time 3600

into /var/www/nextcloud/.user.ini and then restart php-fpm.
systemctl restart php8.2-fpm.service assuming you are using php8.2.


If you want to change it globally and not only for nextcloud, you would need to edit /etc/php/8.2/fpm/php.ini with the lines you already posted (without the php_value in front of every line)

I see, now i understand: different setup for app level and global setting.
Thank you.

One more question: with “=” in the line or without it?

Only if you are in php.ini.

Thank You! Learned AGAIN something.

i have the same issue. I need at least a bit more than 4 GB to- up and download vdisk images.

My /var/www/nextcloud/.user.ini has the following lines:
php_value upload_max_filesize 16G
php_value post_max_size 16G

And i already restarted PHP

My /etc/php/8.2/fpm/php.ini has

upload_max_filesize = 4G
post_max_size = 4G

(having 4G globally is more than sufficient for me)

My Nextcloud still says: max upload file size: 512 MB
What am i missing?

Helped myself:

Looked for all files containing “512M” (for obvious reasons):

sudo grep -rnwi '/etc/php/8.2/' -e '512M'

Changed the values in that file, restarted PHP and… tadaaahhh :smiley:

1 Like