Nextcloud 21 released and won't install on dietpi

I was playing around with nextcloud talk yesterday and something went funny with an upgrade so i decided to do a fresh install of nextcloud/nextcloud talk as it was only installed earlier that day…well it turns out it version 21 was released some point after my first install and now i can’t get everything working again. Everything seems ok with Nextcloud but dietpi won’t let me install nextcloud talk. I was getting a spreed issue. I tried looking into it on nextcloud but it was an old issue for a few years ago and nothing would help me fix it.

  • Date | Mon Feb 22 12:56:46 GMT 2021
  • DietPi version | v6.34.3 (MichaIng/master)
  • Image creator | DietPi Core Team
  • Pre-image | Raspbian Lite
  • Hardware | RPi 4 Model B (armv7l) (ID=4)
  • Kernel version | Linux DietPi 5.10.11-v7l+ #1399 SMP Thu Jan 28 12:09:48 GMT 2021 armv7l GNU/Linux
  • Distro | buster (ID=5,RASPBIAN=1)
  • Command | ncc app:install spreed
  • Exit code | 1
  • Software title | DietPi-Software


what version of NextCloud you are running now?

it’s a fresh install of nextcloud through dietpi-software…it’s installing v21

I did a test installation and once NextCloud was running I installed Talk without issues

 Mode: Configuring Nextcloud Talk: Video calls with configured coTURN server

[ INFO ] DietPi-Software | Configuring TURN server:
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: listening-port=3478
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: fingerprint
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: use-auth-secret
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: realm=DietPi3
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: total-quota=100
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: bps-capacity=0
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: stale-nonce
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: no-multicast-peers
[  OK  ] DietPi-Software | systemctl start mariadb
[  OK  ] DietPi-Software | systemctl start redis-server
[  OK  ] DietPi-Software | ncc maintenance:mode --off
[  OK  ] DietPi-Software | ncc app:install spreed
spreed already enabled
Config value stun_servers for app spreed set to ["DietPi3:3478"]
[  OK  ] DietPi-Software | Comment in /etc/turnserver.conf converted to setting: static-auth-secret=***
Config value turn_servers for app spreed set to [{"server":"DietPi3:3478","secret":"<OMITTED>","protocols":"udp,tcp"}]
[  OK  ] DietPi-Autostart | systemctl daemon-reload

Pls try to install talk app again. Probably there where some issues at Nextcloud download server side due to the new release. Maybe some overload situation.

Hello, I have Nextcloud 20.0.7 running on ODROID-C2.
I want to upgrade to 21. But admin/overview says: It is using MariaDB version “10.1.48-MariaDB-0+deb9u1”. Nextcloud 21 will not support this version anymore and needs MariaDB 10.2 or higher.
What can I do?
Thank you very much, many greetings!

It seems your are still running Debian Stretch looking to MariaDB version. There you basically have 2 options if you like to use NextCloud 21

  1. update your system to Debian Buster
  2. start a new installation using Debian Buster image

Ok, Thank you!
I didn’t realize that this would require an upgrade. Let’s see what I do.

Even if we do not official support an Debian upgrade, following link might be helpful

btw, are you sure you are not able to update NextCloud via Web GUI? I did a test installation on Stretch and it was going to install v21 without issues. At least the installation seems to ignore MariaDB 10.1 :rofl:

Ok, I tried the upgrade and got the allowed memory size exhausted problem.
Probably that:
Any ideas?
Next question: How can I get nextcloud to run under php8?
I am using lighttpd.
Thanks a lot!

I guess the solution for this issue is inside the GitHub post you linked

I now have nc running again. The only thing that helped me was to comment out memcache/redis in config.php.
Probably not a good solution in the long run.
/‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘filelocking.enabled’ => true,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis-server.sock’,
‘port’ => 0,
‘timeout’ => 0,
‘password’ => ‘’,

for information. dietpi v7.0.2:
I updated nextcloud 20.0.9 via the web updater to 21.0.1, it worked well.
Also talk 11.1.2 works well.
i added manually the line ‘default_phone_region’ => ‘DE’, to /var/www/nextclooud/config/config.php

Only remaining “failure message” is
Dein Web-Server ist nicht richtig eingerichtet um

  • “/.well-known/webfinger”

  • “/.well-known/nodeinfo”

aufzulösen. Weitere Informationen findest Du in der Dokumentation.

Regards, droogi

maybe you can have a look to the NextCloud forum

thanks Joulinar for the hint, but this is for apache. Nextcloud is installed with nginx.

I think it should be configured in /etc/nginx/sites-dietpi/diet-dav_redirect.conf, but i am not sure about this and the syntax.

nextcloud help points to
Regards, droogi

probably you can connect to the topic on the nextcloud forum as they are talking about nginx as well.