Nexcloud login not working after updating DietPi v9.2.1

Creating a bug report/issue

i am not able to login nextcloud after updating DietPi v9.2.1 the login page just gets reloaded after entering correct username and password

  1. tried setting maintenance mode on and off no issues observed

---------attaching nextcloud log-----------

{"reqId":"DZdvG0X4TOBDPzpscfAQ","level":1,"time":"2024-04-06T20:38:46+00:00","remoteAddr":"192.168.0.118","user":"--","app":"no app in context","method":"POST","url":"/nextcloud/login","message":"IP address throttled because it reached the attempts limit in the last 30 minutes [action: login, delay: 800, ip: 192.168.0.118]","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36","version":"27.1.7.2","data":[]}
{"reqId":"DZdvG0X4TOBDPzpscfAQ","level":0,"time":"2024-04-06T20:38:47+00:00","remoteAddr":"192.168.0.118","user":"--","app":"no app in context","method":"POST","url":"/nextcloud/login","message":"Logging out","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36","version":"27.1.7.2","data":{"user":"null"}}
{"reqId":"DZdvG0X4TOBDPzpscfAQ","level":1,"time":"2024-04-06T20:38:47+00:00","remoteAddr":"192.168.0.118","user":"--","app":"core","method":"POST","url":"/nextcloud/login","message":"Bruteforce attempt from \"192.168.0.118\" detected for action \"login\".","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36","version":"27.1.7.2","data":{"app":"core"}}
{"reqId":"DZdvG0X4TOBDPzpscfAQ","level":1,"time":"2024-04-06T20:38:47+00:00","remoteAddr":"192.168.0.118","user":"--","app":"no app in context","method":"POST","url":"/nextcloud/login","message":"IP address throttled because it reached the attempts limit in the last 30 minutes [action: login, delay: 1600, ip: 192.168.0.118]","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36","version":"27.1.7.2","data":[]}

I have searched the existing open and closed issues

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname --all
  • Architecture | dpkg --print-architecture
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
  • Power supply used | (EG: 5V 1A RAVpower)
  • SD card used | (EG: SanDisk ultra)

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

Expected behaviour

Actual behaviour

Extra details

Looks like you tried to login to often and your IP was blocked temporarily

I have the same problem too.
After update dietpi, i can’t login in nextcloud. if I reinstall a previous backup, everything goes back to ok. If I redo the updates via sudo apt upgrade I get the same error with nextcloud (temporary error) and it won’t let me log in

Weird, no APT package should have an effect on the internal Nextcloud brute-force protection. Which packages would be upgraded?

apt list --upgradeable

Sorry Michalng, I can’t replicate the update anymore. I reinstalled the backup further back in time but it now includes those updates. I only remember it was 6…7 system packages. They were a few packages. Be careful though, nextcloud works. In fact, synchronization with the PC works and I can also see my files from the Android app. I can’t just log in via browser (brave browser). I use a password manager (the password is correct).

Same question above is for OP. Also essential information is missing, basically what the bug report template asked for, most importantly the Debian version, and in this particular case which webserver was used.

On a fresh Nextcloud installed on a x86_64 Debian Bookworm VM, login works fine.

Hi Michalng …sorry for the delay in replying.
You are absolutely right. With feedback like this it is impossible to find help. I understood the problem!! it was the browser. I use Brave Browser and for some reason, evidently after an update, it stopped working as I told you before.
Installed (on manjaro x86) Firefox everything is back ok.
The system that runs nextcloud is a raspberry pi 4 with obviously dietpi.

Bye

Does the browser console (developer tools) give any hint? However, probably it is really just a bug in Brave, solved in a future version.

it was even simpler… I deleted the cookies and as if by magic everything is now ok even with a brave browser… I don’t know what was bothering me before…

2 Likes