Newbie - ampache login

Hello to all

just wanted to check ampache on RP4.
Downloaded newst dietpi
setup all like wlan, smb mount

add software ampache
choose lighthttp
(add automatic mariadb and some other stuff)

so it looks like no error all fine.
But: loading the website “http://dietpi/ampache” I got a long list of needed updates and pressing the update button makes nothing.
google told me to drop the database und manual install it.
copy here the script:
c> d /tmp

mysql -e “DROP DATABASE ampache;”
curl -sSfL -o ampache.sql
/boot/dietpi/func/create_mysql_db ampache ampache dietpi
mysql ampache < ampache.sql
rm ampache.sql

this bringsup the login page of ampache, but now I’m not able to login…
(yes I choose the user and password from the short description admin/dietpi)

because all work to find a condif file or error massage from lighthttp, I deinstalled all and started again with apache.
same problem and noch httaccess or some entries in config file for apache…

ok - it seams to be a layer 8 problem (means user problem)…
some tips?

Info about rpi4

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • Architecture | dpkg --print-architecture
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
  • Power supply used | (EG: 5V 1A RAVpower)
  • SD card used | (EG: SanDisk ultra)

root@DietPi:~# echo $G_DISTRO_NAME $G_RASPBIAN
bookworm 0
root@DietPi:~# uname -a
Linux DietPi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux
root@DietPi:~# dpkg --print-architecture
root@DietPi:~# echo $G_HW_MODEL_NAME
RPi 4 Model B (aarch64)

dropping database has dropped all user as well :wink: Can you try to open following side http://192.168.0.x/ampache/install.php?action=show_create_account&htmllang=en_US&charset=

Replace IP with your own one. based on Bypassing Ampache Update Page - #5 by mostly_offline

worked - not out of the box, but worked
I got first an error, the some columns were missing, then reinstall software, then the landing page with huge updates worked…
so now it is up an running
will redo that on weekend to get better understanding