New NanoPi Neo3 Doesn't "boot"

I’m new to this mini-boards and I’m having a hard time to get into it, I’ve been using the “default” distro friendlycore-lite-focal-5.15-arm64 and works ok but I’m experiencing some huge IO Wait when using docker and pulling/extracting images, because of that I decided to try DietPi, but I cannot make it work, the unit never gets an IP and the green led blinks twice every 1-3 seconds not sure, with that said here it’s my questions.

  • Is it normal to have a huge IO Wait times on SD cards ? Mine is SandDisk Extreme PRO 128GB SDXC V30 A1 U3

  • How can I understand what is going on with my board not booting DietPI, I know that there is some serial-to-usb, But I’m confused with this one, there are a lot of pin versions 3 pins, 5 pins, 6 pins, and I’m not sure how to use it, I know that my board have 2 UARTS based on the image in this wiki NanoPi NEO3 - FriendlyELEC WiKi, I really apreciate if someone can get me into this UART/Serial debug magic so I can help more this project.

Thanks is advance, hope I can help this community.

Welcome to our community.

@MichaIng can you have a look pls.

Usually you only need to connect three pins, GND, RX and TX.

There are optionally the flow control pins RTS and CTS and the SBC sometimes can also power the UART adapter (usually done via USB otherwise), which then makes up to 6 pins.

As long as there is no dedicated UART port or header, the essential three pins are usually at one edge of the GPIO header. I’ll have a look which UART is enabled by default and which pins it uses on our current NanoPi NEO3 image.

EDIT: Please try to connect to the dedicated three debug UART pins, with RX, TX and GND. The PCB should contain the info which of the pins is which.

1 Like

Thank you.

I’ve bought a “TTL RS232 (CH340G) - JOY-IT” for this, the board have 2 UART as far as I can see, one 3 pins that is separated, this ones is called “Serial Debug Port/DEBUG” I think this is the one you mentioned I should connect, and I have another one but this is within the GPIO Pins and it has the RTS and CTS.

As soon I receive the unit I’ll connect to the Debug UART and report here with my findings, thanks for the help.

1 Like

Ok here it is what I discovered so far and hope this helps newcomers too:

About Serial connection:

I’ve bought this one:

  • TX and RX needs to be crossed, meaning TX on device connects on RX of the adapter
  • Connect the Debug UART to the converter and plug it to the usb before powering the device on.
  • If your device doesn’t boot (no screen/chars) on my case it was a bad SD not sure if that is 100% true for all devices, but it worked after re-inserting a few times
  • I could only get data from the tty with CoolTerm (macos), I’ve tried screen, stty, cu, minicom and no luck on garbage on the screen

About weird stuff

  • For some reason dietpi have a different mac address than FriendlyCore distro.

Hope this info help newcomers, for the dietpi team I’m in love with this distro that is a great work, I’m going to try (no promises) to help maintaining this little board as soon I understand more about this new ecosystem.


Jep, some UART adapters have RX/TX associated to their input/output instead of the devices input/output, some the other way round. Somehow makes sense.

Even if the SD card is bad, the UART console should still show the output of the hardware part. But you meant the physical/HDMI screen, right?

For correct serial console output, the baud rate of the client needs to match, usually 115200. And one might need to take care that flow control is disables on the client, at least not set to RTS/CTS if not connected.

At least the MAC address isn’t randomly set in every boot, is it?

I mean the UART Debug was not sending anything if the sd card is bad or not inserted on my NanoPi Neo3, maybe I missing something but that is how it’s “working” for me

For the serial, I’ve to set 1.5M and the only clients I could make it work were CoolTerm (No ANSI colors) and picom this one worked without a problem.

For the mac it changes between “distros” I was not expecting that since the wiki for nanopi neo3 says: " * LAN: 10/100/1000M Ethernet with unique MAC"

I’ll test UART on my NEO3 as well when I find time, bad if there is no pre-drive output, but would then be out of our control.

I hope the MAC is not somehow hardcoded by bootloader or kernel then. I’ll post mine when testing UART, so we can compare.

No worries I was just explaining my finds to the new comers, let me know and we can compare.

1 Like