NEW Installation failed because of "Temporary failure in name resolution"

I am new on DietPi. I have a new RASPI 4 2GB. I tried to install the “ARMv8 64-bit image”.

After flashing the sd card with Etcher I put the card into my RASPI and started the device. After I logged into the SSH account the DietPi software told me the following error:

Checking DNS resolver                                                        │
│  - Command: ping -c 1 -W 10                                   │
│  - Exit code: 2                                                              │
│  - DietPi version: v7.4.2 (MichaIng/master) | HW_MODEL: 4 | HW_ARCH: 3 |     │
│ DISTRO: 6                                                                    │
│  - Image creator: DietPi Core Team                                           │
│  - Pre-image: From scratch                                                   │
│  - Error log:                                                                │
│ ping: Temporary failure in name resolution

I tried it twice and nothing helped me now!!!

What can I do to install it?

When I try to make the ping to " " in my Linux terminal, the ping worked perfectly!

I also saw, that the resolve.conf file is not in the etc-folder of the dietpi-system.

Please help me!

if you are on the RPI, could you pls try

ping -c 1 -W 10

what is the output of

cat /etc/resolv.conf

ping -c 1 -W 10
DietPi v7.4.2 : 13:49 - Wed 08/25/21

  • LAN IP : (eth0)
    [ OK ] DietPi-Login | Checking network connectivity
    [FAILED] DietPi-Login | Checking DNS resolver
  • Command: ping -c 1 -W 10

root@DietPi:~# ping -c 1 -W 10
ping: Temporary failure in name resolution

cat /etc/resolv.conf:

ok your local IP is your DNS server. Correct? Are you able to ping anything else from your DietPi device like google?

ping -c 1 -W 10

If this is not working as well you probably need to change your DNS server.

  1. In my local router I had the false DNS Server IP. I changed it a few days before because of an experiment with PiHole. Now the connection to DietPi is working.

  2. BUT: The error message was still there. I researched within DietPi. I changed the settings in Timezone and Locale (UTF) to my local settings.

After this the installation worked perfectly!!

are you sure the issue was still the same. Usually time sync issues resulting in different error messages.