New install - packages not updating

Hi there! I was very happy with my move from Raspbian to Dietpi… until I just noticed that some of my packages are not updating. I run the update command in both terminal and via the Dietpi menu, but it doesn’t provide me updates. This applies to both Sonarr and Radarr. Plex Media Server seems up to date.

Any ideas why Sonarr and Radarr are not updating? :thinking:


pls can you let me know the command you are using to update?

I use sudo apt update. I also just added a print screen in the initial post. Thanks!

for Sonarr and Radarr you can check inside the WebGui for updated. usually you should be able to click and install update from there.

Yeah, usually it does but not on my install… see attached

I see that Radarr by the way has a recent date… I thought it was an older version somehow. Well, then it’s just Sonarr not updating…

Edit: solved. Dietpi doesn’t include V3 yet… I upgraded following this post

yes Sonarr v3 is still BETA if I’m not mistaken

Yes, it is and unfortunately Dietpi will wait until it comes out of beta. I had V3 on my previous Rasbian instance and new interface is much better. The update to V3 didn’t go well on Dietpi so I’ll just wait until V3 is supported.

well the Sonarr was done by a nubmer of users already. Means it is working in general.

Yeah, I probably did something wrong. Although install is there according to response, it keeps launching V2. I’ll give up for now :wink:

strange that it has been failed. Usually it’s straight forward activity. Add the new repository + key and install sonarr via apt. :thinking:

I’m a Linux beginner so I probably did something wrong. When I got the question on which user and group to use I ESCed out of it to look up the correct user and group. When I tried to restart the installation again it says V3 was already installed. But V2 was still showing when I opened up Sonarr in the browser. I then removed V2 completely and tried to install V3 again without any luck. Still saying V3 is installed already but I’m not able to open it in the browser. So ended up installing V2 again :wink: .

I could give it another GO if you can help me getting rit ov V3 completely :smiley: so I can go start from scratch with V3.

Appreciate fact you following this topic!

this should answer the question for user and group during sonarr upgrade

And yes the dialog is showing up only once during initial upgrade. That’s how Sonarr guys have build it.

sudo apt update


sudo apt upgrade -y

update only updates the repositories…upgrade updates the programs

well question was about upgrading Sonarr from v2 to v3 and there it is working differently due to the nature of the software title