New install from image - won't boot.

Hi All

First up, thanks for this. Had previously it up and working but I think I ran into the update bug when installing some new software.
I was following the instructions to install SSH instead of Dropbear and it updated the kernel or something and - unbootable.

I’ve given up trying to fix it and am instead just going to install it from scratch.
I’m using an updated version of the VMware image that I used previously (Virtual machine on my Synology NAS). Dietpi_vmware-x86_64-Buster

However, it just doesn’t want to boot.
Initramfs couldnt load padlock-aes.ko no such device.
Waiting for UUID etc.

Then ends in a Kernel panic.

Am I missing a step? Any thoughts please?

I’ve tried using Virtualbox this time - and it’s installing OK (so far). Think I tried it previously and had issues, so switched to VMware image.
No idea why VMWare image isn’t working this time.

Out of interest, is there a step by step for fixing the update bug and non-working boot please?


many thanks for your message. Am I right you like to setup a VM on your Synology? If yes, pls use the VirtualBox *ova files to be imported into your Virtual Machine.

Yes, I’ve tried installing it using the Virtualbpx OVA file. That’s what I’m looking at now.

On this new install. IP Address is pingable but I can’t get to the web interface.

Not sure if Lighttpd is running but any commands I’ve found to start the thing don’t seem to work.
Trying to change to the alternatives and back again don’t prompt an install…

Defaults were chosen throughout the install. IP Address and mask is correct, so it looks like something is broken.

FYI, I get the same error about the missing packlock-aes.ko file, but it continues to the dietpi interface.


I’m lost a little bit on your comments.

If you have a plain/new installation, you are able to login using SSH. There is nothing else installed. Required software title would need to be installed after finishing first setup.

Whoops… Ignore me! Brain fart; I missed a step! :slight_smile:

I was using the console in the Virtual Machine, so that’s all OK.

However, would like to get to the bottom of the original problem when updating and how to recover from the bug.

not sure if this is fitting yours but there was/is an issue with the grub package (Debian Bug)

Would be good to know what was the exact error once your system was not booting. If you using Synology Virtual Machine Manager, you are able to connect to the system via web interface to check why its hanging during boot.

Yeah, was same bug that led me to wanting to reinstall.
Original error was
“symbol ‘grub_calloc’ not found”

After a reinstall, it’s back up and running. Needless to say, I will be cloning it - even for (what I thought was a) relatively minor software upgrade.

unfortunately such bugs is out of DietPi control as we don’t maintain packages from official Debian repository. We just can try to find a workaround and inform our users. But good that you were able to fix it.