New bullseye install on ESXi , can’t boot

Hey all ,
I have been successfully running dietpi as an esxi VM on buster. I today wanted to create a new dietpi VM , so downloaded the VMware bullseye vmdk , and used vmdk tools (as I did with the previous version )
Unfortunately it doesn’t boot with a message initramfs: Waiting for UUID xxxxx to appear.

Not sure if this is a driver issue etc.
anybody managed to install on esxi ?

I was able to use the pc image iso to build , but not sure the implications of this.

I am experiencing the same issue, initramfs waiting for UUID=xxxxxxx to appear.

If anybody could shed some light on this one, I would be really appreciative.

I’m running into the same problem. I tried converting the image for esxi but it only works when you open it in windows vmware workstation software.

I got it working, in short

download debian-11.1.0-amd64-netinst.iso

Create a VM
walk through the steps
I changed settings memory,hdd, select ISO (debian-11.1.0-amd64-netinst.iso)
and start install
I dont need a GUI, just standard system utilities & openSSH server

get IP with ip a
Use Putty to login

After login
enter su - (use root password)
enter apt update
enter apt install -y curl ca-certificates systemd-sysv
enter bash -c “$(curl -sSfL ‘’)”
select master image
enter a name
enter a pre-image name → debian
select nr. 20 - x86_64 Virtual Machine
choose Wifi if you need it
choose Bullseye
sit back and relax.
finished? then reboot
Done, DietPi on ESXi

Basically it is described like this on our online docs to create your own image.

Thanks @rafiki Joulinar worked great for me . !

Hi guys,

it’s a while but maybe you like to test our new ESXi image. It’s currently in testing phase and require ESXi 6.5 as minimal version.